Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a computer running xubuntu 13.10, and a flash usb drive Kingston. My friend gave it to me and I do not know why the computer did not regconize it. Here is the result after running sudo fdisk -l

Disk /dev/sdb: 7747 MB, 7747397632 bytes

239 heads, 62 sectors/track, 1021 cylinders, total 15131636 sectors

Units = sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 512 bytes

I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk identifier: 0x00000000

Then I used gparted trying to format it, gparted said it is unallocated, and we can't created partition table on it.

I also tried Disk ultility but it crashed everytimes, with the error:

Error synchronizing after formatting with type ``dos'``: Timed out waiting for object (udisks-error-quark, 0)

Please help me to rescue it.

Thanks.

share|improve this question
    
Did you try unmounting it and then using gpart? –  Mr.Lee Feb 21 at 4:07
    
Yes, I tried it by using umount /dev/sdb and using gparted agian, but nothing happened. –  Nguyễn Duy Khánh Feb 21 at 6:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.