Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to setup an unattended install of Xubuntu 13.10. It currently picks up all the settings but it still requires me to click next on each screen. I understand editing the xubuntu.seed isn't best practice however I'm just trying to get it to get working.

I have tried automatic-ubiquity and priority=critical but neither seems to make a difference; I have a feeling the install process is being called from somewhere else, bypassing these settings.

txt.cfg

default live-install
label live
  menu label ^Try Xubuntu without installing
  kernel /casper/vmlinuz
  append  file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
label live-install
  menu label ^Install Preseed Xubuntu 13.10
  kernel /casper/vmlinuz
  append  file=/cdrom/preseed/xubuntu.seed boot=casper languagechooser/language-name=English countrychooser/shortlist=NZ localechooser/supported-locales=en_US.UTF-8 automatic-ubiquity initrd=/casper/initrd.lz quiet splash priority=critical --
label check
  menu label ^Check disc for defects
  kernel /casper/vmlinuz
  append  boot=casper integrity-check initrd=/casper/initrd.lz quiet splash --
label memtest
  menu label Test ^memory
  kernel /install/mt86plus
label hd
  menu label ^Boot from first hard disk
  localboot 0x80

xubuntu.seed

# Enable extras.ubuntu.com.
d-i apt-setup/extras boolean true
# Install the Xubuntu desktop.
tasksel/first multiselect xubuntu-desktop
d-i console-setup/ask_detect boolean false
d-i console-setup/layoutcode string us    
d-i debian-installer/language string en
d-i debian-installer/country string NZ
d-i debian-installer/locale string en_NZ.UTF-8
d-i time/zone string Pacific/Auckland   
d-i mirror/http/mirror select nz.archive.ubuntu.com
d-i clock-setup/ntp boolean true
d-i netcfg/choose_interface select auto
d-i netcfg/get_hostname string Xubuntu-undefined
d-i grub-installer/only_debian boolean true
d-i passwd/user-fullname string Administrator
d-i passwd/username string user
d-i passwd/user-password-crypted password $1$D8xyolIs$nDCtVHsk5r0UeNyvVjK.D0
d-i passwd/auto-login boolean true
d-i finish-install/reboot_in_progress note
d-i preseed/late_command string echo 'x11vnc -usepw -forever' >> /etc/rc.local; chmod +x /etc/rc.local; apt-get install remmina, x11vnc

For safety, I haven't specified whether to automatically format sda until its ready.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Fixed this using a related question

I took the params from my txt.cfg, backed up my syslinux.cfg file and replaced all the lines with the params.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.