Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alright guys I'm new here and I need a hand, I've looked at dozens of other posts and nothing has helped me solve this. I'll try to give as much information as possible but if you need more just say so.

First, I will explain what I am trying to do. I have a Lenovo T430s, running windows 8.1 (64 bit) and I have 8 GB of RAM. I took the hard drive out of my old Toshiba laptop and turned it into an external hard drive. I want to install Ubuntu on that so I can have the OS without actually changing any of the internal stuff of my laptop. From what I understand on how it is supposed to work I should just be able to plug in the HDD before start up and it will boot Ubuntu instead.

What I did:

  1. Changed my bios settings so USB drives are first.

  2. Downloaded the Ubuntu iso file. I have tried with both Ubuntu 12.04.4-desktop-amd64 and 13.10-desktop-amd64.

  3. Checked the Hash with Winmd5sum, its all good according to that.

  4. Used Linux live usb creator with my 32 GB Verbatim flash drive.

  5. Restarted my computer with both the flash drive and the external HDD plugged in, chose to install Ubuntu.

  6. Did the install stuff, pretty sure I got it right. Went with "something else", then used the external drive. I tried a few combinations of partitions but I keep getting the same result. The setup I want and I think should work is this: First I partitioned off 500 MB for "/Boot", Ext4 format. Then I did 60 GB for "/", Ext4 format (figured I might as well have lots of space for programs). Then I did 8 GB for swap. Then finally around 60 GB or so for "/Home", Ext4 format (not entirely sure on the /home size, I just wanted to leave 100 GB for a nfts format so both OS could access the same files, so the remaining memory went to /home). Then I changed the "boot from" or whatever it says for that bar across the bottom to the /Boot partition.

The rest of the install is pretty straight forward, everything seems to go smoothly and then it tells me that I need to restart, so I do. But I cant boot from the HDD. If I don't have the flash drive plugged in nothing happens. I've tried pushing Enter (thats what it is for Lenovo at startup) and then trying to "boot from once" with the HDD, it just goes blank for 0.5-1.5 seconds then brings me back to the same page, eventually I just have to pick my internal drive and start windows.

Some posts I've seen say to boot from the flash drive again and repair the install, but I dont have a repair option. I can scan for errors though and with the 12.04 it says 2 errors (no details or help on how to fix them) and with 13.10 I get 1 error.

I don't know where to go from here. I just wanted to be able to do my homework without having to go to the computer lab haha. Any help will be greatly appreciated.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.