Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of, some revelant tidbits about my browsing-related settings:

  • Xubuntu 13.10

  • Firefox 27.0.1, to which I updated this morning I believe.

  • I did not change any proxy settings in Firefox.

  • The problem does not occur in Chromium.

Active add-ons are:

  • Noscript 2.6.8.14

  • Reddit Enhancement Suite 4.3.1.2

  • Ubuntu Firefox Modifications 2.8

Since my latest boot, which was circa 2 hours ago, I have to "full refresh" every single page I visit. It says "Page not found" on each first visit, whether it is askubuntu.com, reddit.com, twitter.com and so forth. Sometimes I even have to hit Ctrl + R twice or thrice. Before this, I think in the last 24 hours, I sometimes (although in a very rare fashion) experienced some pages not loading fully.

What is causing this? How can I solve this issue?

Additional info after DK Bose's posts

With all extensions disabled it worked sporadically better I'd, but sometimes just as buggy, for example with ubuntu-manual.org.

Starting Firefox with a new profile (via firefox -ProfileManager) also didn't change things:

I'd say it was equally bad. As reddit.com and ubuntuusers.de were loaded just normally in Chromium, it seems to be connected to Firefox on Ubuntu. Hm... really do not have a clue what is happening.

share|improve this question

closed as off-topic by LnxSlck, Braiam, Alvar, Amith KK, Eric Carvalho Mar 10 at 12:48

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – LnxSlck, Eric Carvalho
  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, Alvar, Amith KK
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Do you the same problem with all extensions disabled (Alt > Help > Restart with addons disabled)? Or did you try new profile (firefox -P)? –  DK Bose Feb 20 at 17:18

1 Answer 1

There are some things to do which help diagnose and hopefully solve your problem.

  • Use the Restart with Addons Disabled option under Help. This is also called Safe mode and the link explains its use.

  • Use the Reset Firefox option available under Help, Troubleshooting Information. That is explained in Reset Firefox – easily fix most problems.

  • Of course, you can also do somethings yourself:

    • empty your cache by pressing CtrlShiftDelete and choosing appropriate options.
    • create a new profile by starting Firefox from a terminal using firefox -P. This will invoke a window which allows you to create a new profile. If you don't have the problem with the new profile, you could migrate several useful things like bookmarks and passwords over to the new profile. This maybe necessary if something in your olde profile corrupted and is difficult to trace.

I also use Firefox and have not had problems but one of the methods listed above should help you!


I realize I have not said what could cause the problem because I have not met it myself and not seen discussion of it elsewhere!

share|improve this answer
    
Yup, the question isn't answered but the problem was solved. I deleted everything via CTRL + SHIFT + DEL and now I can browse normally again. –  henry Feb 20 at 19:06
    
Actually, it wasn't. My flatmate reported the same problem on his Windows machine. He then reconfigured the DNS something something in the router to another server of our internet provider and now says the problem is solved. So far I can say the same but I'm staying cautious. Never experienced that DNS servers show that kind of faulty performance, it's a bit odd. –  henry Feb 20 at 19:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.