Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 11.04, and the unity launcher is really giving me a headache:

  1. sometimes it gets stuck in the open mode.
  2. after turning on the "auto hide" in compiz-config it does disappear, but pops up every time my cursor goes to the left part of the screen in a way the doesn't allow me to click on stuff there (i.e. the back button in mozilla).
  3. configuring the "reveal mode" to be TopLeft, doesn't help: the lancher doesn't appear but still somehow blocks me from clicking stuff in the area where it's supposed to be

what's up with that?

share|improve this question
    
You might need to reset your unity settings: askubuntu.com/questions/17610/… –  Jorge Castro May 13 '11 at 16:34
add comment

3 Answers

up vote 1 down vote accepted

A lot of the sticking/stacking issues are actually Compiz bugs. Recently the Compiz developers gave me a really useful workaround tip:

  • Ctrl+Alt+RightArrow (switch to next virtual desktop)
  • Ctrl+Alt+LeftArrow (switch back to original virtual desktop)

If Unity/Compiz gets really stuck (quite rare these days, but I appreciate that it may still happen), then a workaround that keeps all of your applications and work is:

  • Ctrl+Alt+F1 (switch to console and login)
  • killall -9 compiz
    unity --replace
  • Alt+F7 (switch back to graphical login)

Waiting 15 seconds will cause the windows to all re-appear. If the stacking is still broken, you can do the double-desktop switch at the top to hopefully clear it.

share|improve this answer
add comment

I had been messing with this for about 2 weeks before I figured out how to switch to classic mode. Ubuntu seems to appear differently on some peoples computers. For one thing, I had no log out option. To log out press Alt + F2. Then paste the following into the text box and press enter:

gnome-session-save --force-logout

Once to the log in screen. If your computer is like mine, there still are no desktop options to be seen anywhere. At this point press Enter two times, and the desktop options will show up at the bottom of the screen. Choose the one you want(for instance classic is just like Ubuntu 10.10 default) and then log back in.

share|improve this answer
add comment

When the launcher gets stuck (does not hide even when there is a maximised window open): select some text (in a browser or text editor, or a file in nautilus), and drag it towards the launcher, 'pushing' the cursor against the left of the screen until the launcher disappears. It works for me every time that happens.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.