Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When at home I prefer to plug my laptop into an external monitor, attach an usb mouse and keyboard, and pretend I'm not working off of a laptop.

Works great at first...

However, my laptop monitor keeps turning back on.

I go to System -- Monitor Preferences -- and turn off the laptop screen and it works beautifully. Exactly how I want it to look.

And then spontaneously Ubuntu turns my laptop monitor back on, attaches it to the right of my desktop, and I loose my mouse from time to time...

It is not at any sort of regular interval that I have noticed -- but it happens more than once a day. Have not noticed any regular behavior that causes it.

By loading up Monitor Preferences I can select the laptop monitor and once again turn it off... but I'm getting a little tired of doing so.

Any suggestions?

share|improve this question
    
Update: Have walked away and come back to find the laptop screen back on. Must be some internal process, not something I am directly doing myself. Also noticed it happened once when I interrupted the computer from going into the screensaver. Everything flashed and then the desktop had once again been extended to the laptop. –  Jonathan May 15 '11 at 12:46
    
you could use "twin view" and just turn off your laptop screen. What settings do you use separate x screen? twin view? Since I don't know if this would work or if I'm just wrong I wont put it as an answer jet. You could get more stable and better software if you upgrade to 11.04. What hardware do you have? it's not surten that it's that well supported. –  Alvar Jun 12 '11 at 21:34
    
Have you tried disabling the screensaver? –  Detnuomnu Jun 12 '11 at 22:09
    
Just a thought, but can you edit your question to include the Screen Saver and DPMS sections from the output of this command: xet q –  djeikyb Aug 9 '11 at 18:08
    
I also have an external monitor plugged into my laptop, but I'm curious why you don't like having both. I find it very useful. –  Thomas Boxley Aug 21 '11 at 8:24
add comment

1 Answer 1

This issue sounds like a bug in the power saving settings, the screensaver timer doesn't turn the screen off, but the power settings do. you have two jobs to do:

Firstly report the bug in launchpad:

https://help.ubuntu.com/community/ReportingBugs

Secondly go into System > Preferences > Power Management, or type power management into the unity interface. When on mains power, tell it to not put the display to sleep:

Power Manager Window Showing Put display to sleep: Never

This isn't a fix, it's only something to help you cope. Please still report the bug.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.