Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why WiFi don't work in my Dell Inspiron 510m with Ubuntu 10.04?

Is that usefull?

inspiron@Inspiron:~$ rfkill list all 
inspiron@Inspiron:~$ sudo lshw -C network 
[sudo] password for inspiron: 
  *-network:0 DISABLED    
       description: Wireless interface 
       product: PRO/Wireless LAN 2100 3B Mini PCI Adapter 
       vendor: Intel Corporation 
       physical id: 3 
       bus info: pci@0000:01:03.0 
       logical name: eth1 
       version: 04 
       serial: 00:0c:f1:5b:5d:40 
       width: 32 bits 
       clock: 33MHz 
       capabilities: pm bus_master cap_list ethernet physical wireless 
       configuration: broadcast=yes driver=ipw2100 driverversion=git-1.2.2 firmware=712.0.3:3:00000001 latency=32 link=no maxlatency=34 mingnt=2 multicast=yes wireless=unassociated 
       resources: irq:5 memory:fcffe000-fcffefff 
  *-network:1 
       description: Ethernet interface 
       product: 82801DB PRO/100 VE (MOB) Ethernet Controller 
       vendor: Intel Corporation 
       physical id: 8 
       bus info: pci@0000:01:08.0 
       logical name: eth0 
       version: 81 
       serial: 00:11:43:41:d8:b8 
       size: 10MB/s 
       capacity: 100MB/s 
       width: 32 bits 
       clock: 33MHz 
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation 
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=half firmware=N/A ip=192.168.0.2 latency=32 link=no maxlatency=56 mingnt=8 multicast=yes port=MII speed=10MB/s 
       resources: irq:11 memory:fcffd000-fcffdfff ioport:ecc0(size=64) 

inspiron@Inspiron:~$ iwconfig wlan0 
wlan0     No such device 

inspiron@Inspiron:~$ ifconfig -a 
eth0      Link encap:Ethernet  Endereço de HW 00:11:43:41:d8:b8  
          inet end.: 192.168.0.2  Bcast:192.168.0.255  Masc:255.255.255.0 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1 
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0 
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0 
          colisões:0 txqueuelen:1000 
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) 

eth1      Link encap:Ethernet  Endereço de HW 00:0c:f1:5b:5d:40  
          BROADCAST MULTICAST  MTU:1500  Métrica:1 
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0 
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0 
          colisões:0 txqueuelen:1000 
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) 
          IRQ:5 Endereço de E/S:0xe000 Memória:fcffe000-fcffefff 

lo        Link encap:Loopback Local  
          inet end.: 127.0.0.1  Masc:255.0.0.0 
          endereço inet6: ::1/128 Escopo:Máquina 
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1 
          pacotes RX:628 erros:0 descartados:0 excesso:0 quadro:0 
          Pacotes TX:628 erros:0 descartados:0 excesso:0 portadora:0 
          colisões:0 txqueuelen:0 
          RX bytes:50104 (50.1 KB) TX bytes:50104 (50.1 KB) 

inspiron@Inspiron:~$ nm-tool 

NetworkManager Tool 

State: connected 

- Device: eth1 ----------------------------------------------------------------- 
  Type:              802.11 WiFi 
  Driver:            ipw2100 
  State:             unavailable 
  Default:           no 
  HW Address:        00:0C:F1:5B:5D:40 

  Capabilities: 

  Wireless Properties 
    WEP Encryption:  yes 
    WPA Encryption:  yes 
    WPA2 Encryption: yes 

  Wireless Access Points 


- Device: eth0 ----------------------------------------------------------------- 
  Type:              Wired 
  Driver:            e100 
  State:             unmanaged 
  Default:           no 
  HW Address:        00:11:43:41:D8:B8 

  Capabilities: 
    Carrier Detect:  yes 
    Speed:           10 Mb/s 

  Wired Properties 
    Carrier:         off 


inspiron@Inspiron:~$ 
share|improve this question
    
Maybe because you are using WiFi hardware that needs propriety drivers. Have you check Additional Controlers (In Spanish Controladores Adicionales). If nothing appear, can you tell us wich WiFi card are you using. –  Martín Casco May 12 '11 at 23:14
    
I'm beginner. How can i check Additional Controlers? Could you decifrate this? –  user17449 May 14 '11 at 15:49

3 Answers 3

You do have a driver installed. This is shown by lshw -C network as ipw2100. It is confirmed by nm-tool which lists driver: ipw2100. This is for an Intel Pro/wireless adapter.

Did you notice that nm-tool labels the wireless adapter as eth1. It usually is wlan0 but as these wireless adapters are also ethernet devices it may not mean too much.

When you click on the network icon do you see a tick mark against Enable Network and Enable Wireless? If not click on those lines and reboot. Clicking these lines acts like an on/off switch. You need both ticked to get wireless networking.

You can also try these commands

rfkill list

If you see soft blocked: yes, then wireless has not been switch on in the OS. If you see hard blocked: yes, then the wireless adapter is switched off at the keyboard.

You could try

rfkill unblock wifi

or sudo ifconfig wlan0 down follwed by sudo ifconfig wlan0 up. You may need to use eth0 instead of wlan0

another command that is useful is

cat /etc/network/interfaces 

This should show

auto lo
iface lo inet loopback

If it shows anything else then you need to edit out the extra stuff by

gksudo gedit /etc/network/interfaces

This will help. In trying to fix problems like this we some times make things worse. These command may help put things right.

share|improve this answer

Martin Casco means 'Additional Drivers'. Search for the application in the main menu (top left of screen/Super key). It searches for missing drivers for graphics cards, wireless cards etc and lets you install them.
If no wireless drivers appear, that is another problem.

share|improve this answer

If I remember correctly, there were 2 different options available when ordering Inspiron 510m: 1. Intel Wireless Card. 2. Some Dell Wireless Card.

Intel Wireless Card worked perfectly fine for me with every single Ubuntu version for the past 5 years. No need to do anything extra. (of course, you need to make sure the wireless is turned on)

share|improve this answer
    
i think the problem is to turn on the Intel wireless card. But i don't know how can i do that. Fn+F2 don't work. –  user17449 May 14 '11 at 15:46
    
Can you understand that? –  user17449 May 14 '11 at 15:51
    
How to log-of from ask-ubuntu? –  user17449 May 14 '11 at 15:59
    
Strange, Fn+F2 works for me. You may try turning on wireless before ubuntu boots - immediately after switching on the computer. Another suggestion - try Ubuntu 10.10. I think I had some problems (but not wifi) with 10.04. –  Vilmantas Baranauskas May 16 '11 at 7:58
    
@user17449, I have seen people are not able to turn on the wireless cards bcuz of the missing drivers. follow the instruction given by The Nagative Shape to install the drivers. –  Abhijeet Jul 23 '11 at 5:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.