Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to get Ubuntu to work (dual booted with Win7) on my new computer for a week now and have not found a working solution. System specs:

  • Intel Core i7-4771 @ 3.50 GHz
  • 250 GB SSD Samsung 840 EVO
  • 16 GB RAM
  • Nvidia GeForce GTX 660

The last item is the suspected culprit...

I first installed 12.04 which worked fine (but did not detect my nvidia card) until it updated, then one of two things happened (I have reinstalled 12.04 several times): 1) I got a white screen but with the mouse visible, and it was possible to open a graphical terminal with Ctrl-t and run programs from there. 2) After updating the nvidia driver I got a completely black screen and could not even open a terminal using Ctrl-Alt-F1.

I then tried installing 13.10 but it freezes on splash screen and I cannot use Ctrl-Alt-F1 to open a terminal. I can't even get the keyboard to work in failsafe mode!

I'm not familiar with debugging this kind of problem and would really appreciate help. As it is now i can't use Ubuntu, which is a shame...

share|improve this question
    
It might be hardware problem with your Nvidia GeForce GTX 660 graphics card. If nothing else works have someone check your graphics card. –  karel Feb 21 at 15:13
add comment

2 Answers 2

I suppose you updated your video driver using the nvidia-331 driver package which includes the latest driver for your video card. And you used in a terminal some code like this one:

sudo apt-get install nvidia-331

or maybe you used the 304 version

sudo apt-get install nvidia-304

I guess the nvidia-304 package is ok for your video card but I am not sure since I have never tested it. I hope you have not updated video driver to nvidia-319 since this one can cause problems for GeForce 600 series graphic cards.

Nvidia-331 should work fine for you but if it doesn't then I suggest you install a fresh copy of ubuntu 13.10. I am a newbie, and I don't like ugrading to a higher version of ubuntu because I know very little about linux, and I could end up just like you with problems that I cannot solve by myself.

As for your video card, you should try go to NVIDIA website, in the Drivers section, and look for a linux driver in there : GeForce - GeForce 600 series - GeForce GTX 660 - Linux 32 or 64 bits, whatever you're using. There are plenty of tutorials on how to install a genuine NVIDIA driver in ubuntu, and if you can find a decent video driver, updating the drivers for your video card should not be a problem.

share|improve this answer
add comment
up vote 0 down vote accepted

Thanks for the reply floppy!

What I did in the end was to do a clean install of 12.04 and install nvidia-304. Then I got the familiar black screen with a white-outline cross, but when I typed my password and hit "enter" i got a white screen and could do Alt-t to open a terminal.

What eventally solved it was switching to Unity 2d by typing:

sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu-2d

Now, after installing mesa-utils, the system recognized my graphics card and I can see that it is in use by using the command:

sudo /sbin/lsmod | grep nvidia

I will have to make due with unity 2d :)

share|improve this answer
    
I am glad you solved your problem, Mikael. Nevertheless you should look for decent drivers [link]nvidia.com/Download/index.aspx?lang=en-us . Check the Beta and Older Drivers located at the middle of the page, select your video card from there, and you get a complete list of drivers for linux 32 or 64 bits. You should download more than one or two drivers from that list. Test them one by one since the Nvidia installer removes previous drivers, and installs a second one or a third one until you find a driver that works best. Remove NOUVEAU driver first, and also blacklist NOUVEAU. –  floppy Feb 23 at 5:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.