Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay folks, hope all is well in which ever part of the world you are in, I seem to be having a bit of an issue with unity-place-applications & unity-place-files.

I have just updated from 10.04 to 10.10 trying to take baby steps on my way to natty anyways the offending party seems to be a dependency which is zeitgeist-fts-extension an attempt to correct things with

sudo apt-get install -f

/

sudo apt-get install zeitgeist-fts-extension -f

doesn't work, I have attempted to use software center, synaptic and all the terminal knowledge I can master but alas I keep getting the error:

The following NEW packages will be installed:
  zeitgeist-fts-extension
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0B/9,280B of archives.
After this operation, 86.0kB of additional disk space will be used.
(Reading database ... 289477 files and directories currently installed.)
Unpacking zeitgeist-fts-extension (from .../zeitgeist-fts-extension_0.0.6-0ubuntu1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/zeitgeist-fts-extension_0.0.6-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/share/zeitgeist/_zeitgeist/engine/extensions/fts.py', which is also in package zeitgeist-extension-fts 0.0.1~bzr20100717-0ubuntu1~ppa1~lucid
Errors were encountered while processing:
 /var/cache/apt/archives/zeitgeist-fts-extension_0.0.6-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now I see a reference to lucid though a quick check with my sources list reveals that all seems well and only maverick is in charge of things. /*cant post sources.list too much html hyperlinks */

Now I am at a loss because I cannot fix this and would really like to so I can move on and try out some other stuff any help will be greatly appreciated, thanks :)

Buyo

share|improve this question
add comment

1 Answer

The error message says you are trying to install a "lucid" package although you have upgraded to maverick.

Sometimes you can do this, but it isnt recommended - in this case, it doesnt look like you can.

The ppa you are trying to install from - can you supply a link in your question.

In the interim, comment out the ppa in your software sources.

then run

sudo apt-get clean

to tidy up your package manager.

share|improve this answer
    
Aah after some wrestling with my laptop I finally found the problem. My sources list was fine the problem was with zeitgeist-fts-extension & Zeitgeist-extension-fts. One of the two was an older package that seemingly got install and the newer version couldn't overwrite the old one. So I sudo synaptic in the terminal and managed to removed the obsolete version installed the correct version and now I am officially rocking! :) Will try out 10.10 for a while then upgrade it also! :) –  devicehandler May 13 '11 at 10:22
    
@devicehandler please answer your own question and Mark as answered –  Minato Namikaze Feb 11 '12 at 9:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.