Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This just happened today. Nautilus (3.8.2) on my Ubuntu 13.10 machine used to work fine, but now, when I try to run it (either from the icon or command line), it opens for about a second and then closes/crashes. The behaviour from the command line is as follows:

me@Bedrock1:~$ nautilus
sys:1: Warning: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(nautilus:3388): GdkPixbuf-CRITICAL **: gdk_pixbuf_loader_close: assertion 'GDK_IS_PIXBUF_LOADER (loader)' failed

(nautilus:3388): GdkPixbuf-CRITICAL **: gdk_pixbuf_loader_get_pixbuf: assertion 'GDK_IS_PIXBUF_LOADER (loader)' failed
sys:1: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Segmentation fault

Does this make any sense? Is there an easy way to see if I installed any libraries yesterday or today, that may be causing this problem?

For now, I'm avoiding the problem by using Dolphin, but am worried there's a problem that will bite me in other applications.

share|improve this question
1  
Did you try to reconfigure it? sudo dpkg-reconfigure nautilus Did you install any software after the last time it worked? –  the_Seppi Feb 19 at 21:46
    
@the_Seppi - I just tried sudo dpkg-reconfigure nautilus, but it didn't work. I'm not certain whether I installed new libraries yesterday. I've been looking to see how I can find out. So far, the best I can do is see which packages I've installed, but not when I did it.... –  user1245262 Feb 20 at 1:14

2 Answers 2

up vote 0 down vote accepted

I don't understand how I fixed it, but this is what I did:

I uninstalled & reinstalled python-nautilus & tortoisehg-nautilus using Synaptic. I came upon this solution as follows:

1 Further web-searching revealed that python-nautilus can cause the 
  Nautilus crash I saw, so I used Synaptic to uninstall it  (i.e. python-nautilus)

When python-nautilus was uninstalled, tortoisehg-nautilus was also uninstalled. This made nautilus work again, but .....

I had since learned how to view my installation history, and saw that the most recent installations I had before my problem were of xsane-common, xsane & sane. Since the two packages I unistalled had been on my system before the problem appeared, I decided to reinstall them and then see which of the sane installs caused my problem with Nautilus.

2 Upon reinstalling python-nautilus & tortoisehg-nautilus, Nautilus continued to work.

So, I don't know what originally caused my problem, nor do I understand why an uninstall/reinstall cycle should have fixed it.

share|improve this answer

I also have this problem with nautilus in 13.10 ; Did you have Clam antivirus installed the new version appears to scan a folder on opening causing it to crash; after reading your problem and solution I went to have a try my self with your solution using synaptic. when I went to un-install python nautilus it gave the message that clam would have to be removed, I did this with the software centre rebooted and nautilus worked no further install needed.

It could be that a recent update for ubuntu may have been the root cause, but what that is I can't say, but its left nautilus vulnerable to crashes. I will point out that I had also reloaded 13.10 yesterday and nautilus worked fine with all my programs up till today and opened folder windows with no problem until an update was downloaded.

I will say this though since I removed clam a few minutes ago and rebooted the folders are opening far quicker and so far no crash. and having just put it through its paces it seems fine at the moment, the only thing I can think of that may be a problem is the new shell integration of clam its a lot more invasive than it used to be and the new interface is I would say more than a little buggy.

share|improve this answer
    
Nope, I am not using Clam... –  user1245262 Mar 20 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.