Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Xubuntu 11.04 on my netbook and I'm noticing a problem with the workspace setup. If I log in, I see there's only one workspace specified. If I load the 'Workspaces' control panel widget and alter it to 4, this works fine until I reboot and log in again, at which point the number of workspaces is reset to 1.

How do I get XFCE4 to remember my workstation number preference?

share|improve this question
1  
Have you installed compiz? Is xfsettingsd running? If compiz is installed, you must change the workspaces using ccsm. –  charlie-tca May 15 '11 at 20:43
add comment

2 Answers

Please check this file:
~/.config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml

It is where the numbers of workspaces are defined in xfce.

share|improve this answer
    
I'm at mobile phone right now, I will put more details ASAP ;-) –  desgua May 16 '11 at 11:01
    
changing the workspaces value in that file doesnt take effect until you logout and login or reboot. It will be interesting to see if the OP issue is due to something resetting that file back to its defaults. –  fossfreedom May 16 '11 at 20:48
    
For some reason, after having checked the permissions twice, if I explicitly set the ownership of xfwm4.xml I seem to have fixed the problem. Not sure why doing a chown on the file specifically rather than the overall directory would have a different effect, but there it is. –  growse May 21 '11 at 16:52
    
I'm glad it is working now ;-) –  desgua May 21 '11 at 18:28
    
Tell a lie, it's back to not working. Oddly enough, it's just that one parameter that's being replaced, and only on login. If I set workspace names, they are persisted, but the workspace_count parameter is still being reset to 1. Is there any way I can figure out what processes are accessing that file during a certain time period? –  growse Jun 8 '11 at 22:33
show 1 more comment

Ensure you own the ".config/xfce4/xfconf" directory, and that you have the right permission on it:

sudo chown -R YOUR_USER:YOUR_GROUP .config/xfce4/xfconf

chmod -R 755 .config/xfce4/xfconf

Substitute YOUR_USER:YOUR_GROUP with your user and group (eg. "growse:growse")

share|improve this answer
    
Yes, I've got the correct ownership of that directory and all files inside it, with the correct permissions of them. –  growse May 15 '11 at 10:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.