Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed Ubuntu 12.04 LTS on my laptop and the only way to get Ubuntu to boot is if I go to boot manager and start it from a UEFI partition called UEFI, if I don't do that I just get a screen telling me my mac address and then telling me to insert a bootable device. I can't see that partition in the BIOS so I don't know what to do, any help would be great.

P.S. I am not dual-booting this with windows.

  1. fdisk -l results:

     WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The
    util fdisk doesn't support GPT. Use GNU Parted. Disk /dev/sda: 750.2
    GB, 750156374016 bytes 255 heads, 63 sectors/track, 91201 cylinders,
    total 1465149168 sectors Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes I/O size
    (minimum/optimal): 4096 bytes / 4096 bytes Disk identifier:
    0x00000000 Device Boot Start End Blocks Id System /dev/sda1 1
    1465149167 732574583+ ee GPT Partition 1 does not start on physical
    sector boundary.
    
  2. Parted -l results:

    Model: ATA Hitachi HTS54757 (scsi) Disk /dev/sda: 750GB Sector size (logical/physical): 512B/4096B Partition Table: gpt Number
    Start End Size File system Name Flags 1 1049kB 512MB 511MB fat32 2
    512MB 744GB 744GB ext4 boot 3 744GB 750GB 5877MB linux-swap(v1)
    Warning: Unable to open /dev/sr0 read-write (Read-only file system).
    /dev/sr0 has been opened read-only. Error: /dev/sr0: unrecognised
    disk label
    
share|improve this question
    
could you please add the outputs of sudo fdisk -l and sudo parted -l to your question. –  JohnnyEnglish Feb 19 at 19:52
    
well did you follow this? help.ubuntu.com/community/DiskSpace –  JohnnyEnglish Feb 19 at 20:31
    
It all looks correct, I have the fat32 partition, the ext4 partition and a SWAP partition, I wonder why Ubuntu doesn't automatically start. –  user3079781 Feb 19 at 20:48
    
read the answer provided by Rod Smith that's plenty enough –  JohnnyEnglish Feb 19 at 21:22

2 Answers 2

First, when posting the output of text-mode tools like fdisk or parted, please ensure that you preserve line breaks and add four spaces to the start of each line. Because you didn't do this, your fdisk and parted outputs have been reformatted by the forum software and are all but illegible as a result.

As to your problem, you probably just need to register your boot loader with the EFI, as described here; or perhaps you need to use efibootmgr to adjust the BootOrder variable. To know for sure, type sudo efibootmgr -v in a Terminal once you've booted. It should look something like this:

$ sudo efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0003,0006,2003,0001,2001,2002
Boot0000* rEFInd    HD(2,1f4800,82000,5f6b4992-fcfe-4a2c-9e67-98b0a30dfe7d)File(\EFI\refind\shimx64.efi)
Boot0001* Lenovo Recovery System    HD(3,276800,1f4000,de3b7563-97f5-48c6-ab7f-2f5d6d57c644)File(\EFI\Microsoft\Boot\LrsBootMgr.efi)RC
Boot0003* ubuntu    HD(2,1f4800,82000,5f6b4992-fcfe-4a2c-9e67-98b0a30dfe7d)File(\EFI\ubuntu\grubx64.efi)
Boot0006* Windows Boot Manager  HD(2,1f4800,82000,5f6b4992-fcfe-4a2c-9e67-98b0a30dfe7d)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC

The BootCurrent line shows which boot manager was launched for the current boot and the BootOrder line shows the order in which the firmware will attempt to boot each entry. In this example, Boot0000 is both the default first boot entry and the one used for this boot. It corresponds to rEFInd, at \EFI\refind\shimx64.efi on a disk partition with a big long EFI identifier (HD(2,1f4800,82000,5f6b4992-fcfe-4a2c-9e67-98b0a30dfe7d)). Don't worry too much about the disk identifer, but look for an entry for Ubuntu. This example isn't stock Ubuntu because I've installed rEFInd as my boot manager. If yours were working correctly, I'd expect it to be pointing to something more like my Boot0003 entry as the first in the BootOrder list; but the details, including the boot number, will of course differ.

Some EFIs are broken and won't boot anything but the Windows boot loader; or they forget their boot entries between boots. In such cases, you'll need to employ a workaround. The page I referenced earlier describes some of these. If you have problems, post back with details, including your sudo efibootmgr -v output -- but be sure to properly format it!

share|improve this answer

Please could you provide more information?

Make and model of laptop? It is EFI or BIOS based? These terms are used interchangeably when they are in fact not the same thing.

Your partition layout, including partition table type (msdos aka mbr or guid based aka gpt), any flags set (especially the BOOT flag), and which partition /boot lives on. This can all be found in gparted or equivalent.

The screen telling you the MAC address is you network cards PXE boot environment... it can be disabled in setup, or just set below your hard disk in the boot order.

share|improve this answer
    
The make and model is Packard Bell EasyNote TV11 link I don't really know the other answers. –  user3079781 Feb 19 at 19:53
    
I found the partition that has the /boot mount point it's actually /boot/efi, I also have another partition with the file system ext4. Should I change the flags around to make another one boot? –  user3079781 Feb 19 at 20:08
    
Sounds like you have an EFI system, you need to enter setup during boot and make sure that your hard disk is in the boot list. You may see multiple entries regarding your disk, make sure the EFI version is selected and not BIOS compatability. –  Viperfang Feb 19 at 20:38
    
Actually in the boot priority order it's: 1. HDD : Hitachi HTS547575A9E384 2. ATAPI CDROM : Slimtype DVD A 3. USB FDD : 4. USB HDD : 5. USB CDROM : 6. Network Boot : –  user3079781 Feb 19 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.