Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A standard feature of most of the document editors like TexMaker or Kile is auto-saving as you type. Of course this is generally considered a good thing, but if I'm editing a document that's already synced with Ubuntu One, Ubuntu One syncs the file every time the editor auto-saves. In addition to eating resources, this also usually results in u1conflict files, and at some point I have to log into Ubuntu One via a web browser to remove the file (there are problems building the pdf from the tex source otherwise).

I know I can temporarily disable Ubuntu One, or temporarily move the document being edited to a folder that's not synced, but it's a bit of a pain to have to take these extra steps every time I want to work on a paper. Is there some way to maybe write a script to disable Ubuntu One automatically while a file is open, and wait until I'm finished editing before syncing?

share|improve this question
2  
This was a bug we believe is fixed in natty. Have you tried it there? –  Chipaca May 12 '11 at 22:34
    
@Chipaca is there a workaround for other versions? I don't think it should be necessary to upgrade just to include a single bugfix. –  jozzas May 19 '11 at 1:19
    
I'm using natty. So far I haven't had problems with u1conflict files, but it's still a bit annoying to have a series of pop-up notifications every time I compile the pdf, so I'm still disabling Ubuntu One, or temporarily moving my files to a non-synced folder. –  Sean Fitzpatrick May 23 '11 at 6:19

2 Answers 2

up vote 1 down vote accepted

You can use the Ubuntu One Quicklist to temporary disable the Ubuntu One syncdaemon while you are working on a document. It is not exactly the solution you were searching for but it might make your life easier.

share|improve this answer
    
if the OP doesn't want to upgrade, he can't make use of the quicklists. –  Uri Herrera Jun 5 '11 at 23:13
    
Are quicklists only available for Oneric? I thought I saw a post on OMG! Ubuntu explaining how to get them working on Natty. I'm not a programmer/developer but I'm not entirely incompetent as far as following someone's CLI instructions goes. I'm flagging this as answering my question since it gives me a reason to get quicklists working on my machine, which is something I've been meaning to try anyway. –  Sean Fitzpatrick Jun 6 '11 at 12:13
    
@Uri - I was able to follow the instructions in the link with no trouble - took about one minute. Not sure why the upgrade is needed. –  Sean Fitzpatrick Jun 7 '11 at 3:04

@Chipaca. No, I can easily mess up my U1 when I work with latex editors such as Kile. The syncdaemon will get incredibly confused and I went back to disabling U1 before I start working with Kile. Still, after some latex editing my pc needs sometimes hours to sync a few kb of data.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.