Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Updated:

I have pasted full output of bash command in Ubuntu into here, including ifconfig, ping, nm-tool, modinfo and dmesg | grep e100.

Hi all,

I can surf internet in Windows 7, just pluging in the wired connetion, geting IP via DHCP of LAN network. But I can not access internet in Ubuntu (12.04 LTS, 13.10, or Lubuntu 13.10, or its Live CD)

I have read some similiar posts that are suggested when I was typing the question title, but still failed to find out the solution.

I have tried to upgrade the Intel e1000e driver, after I read the keyword e1000e from a post.

I have edited my eth0's IP and DNS manually instead of DHCP, using same IP values in Windows where network works.

However, I still can not access internet.

I am wondering that:

Why I can access internet in Windows using DHCP, but can not in Ubuntu using DHCP too ?

So i come here for seeking help, below is my network IP information, maybe you can help me to read these data and find out the solution.

Thanks for your help:

ipconfig /all in Windows when I can access internet

 Ethernet adapter ±ŸµØÁ¬œÓ:

 Connection-specific DNS Suffix  . :
 Description . . . . . . . . . . . : Intel(R) 82577LM Gigabit Network Connection
 Physical Address. . . . . . . . . : 00-26-2D-F9-51-71
 DHCP Enabled. . . . . . . . . . . : Yes
 Autoconfiguration Enabled . . . . : Yes
 Link-local IPv6 Address . . . . . : fe80::a4a1:264a:f270:f8eb%13(Preferred)
 IPv4 Address. . . . . . . . . . . : 192.168.0.148(Preferred)
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Lease Obtained. . . . . . . . . . : 2014Äê2ÔÂ19ÈÕ 21:15:21
 Lease Expires . . . . . . . . . . : 2014Äê2ÔÂ19ÈÕ 23:15:24
 Default Gateway . . . . . . . . . : 192.168.0.1
 DHCP Server . . . . . . . . . . . : 192.168.0.1
 DHCPv6 IAID . . . . . . . . . . . : 352331309
 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-8B-D1-4E-00-23-14-39-3E-E0

 DNS Servers . . . . . . . . . . . : 202.96.209.5
                                     202.96.209.133
 NetBIOS over Tcpip. . . . . . . . : Enabled

ifconfig, nm-tool in Ubuntu when I cannot access internet

lubuntu@lubuntu:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:2d:f9:51:71  
          inet addr:192.168.0.148  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::226:2dff:fef9:5171/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:180 errors:0 dropped:0 overruns:0 frame:0
          TX packets:216 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:47107 (47.1 KB)  TX bytes:24199 (24.1 KB)
          Interrupt:20 Memory:f2500000-f2520000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:296 errors:0 dropped:0 overruns:0 frame:0
          TX packets:296 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:23132 (23.1 KB)  TX bytes:23132 (23.1 KB)

wlan0     Link encap:Ethernet  HWaddr 00:23:14:39:3e:e0  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            e1000e
  State:             connected
  Default:           yes
  HW Address:        00:26:2D:F9:51:71

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.148
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             202.96.209.5
    DNS:             202.96.209.133

Here is some extra information:

I am using ThinkPad T410s (here is specification);

In Ubuntu, when I enter any website, I was brought into a router welcome page (192.168.0.1/login.htm) saying words like 'WAN is not connected', but if WAN is not connected to the router, how can I access internet perfect in Windows.

share|improve this question
    
It looks as if you are connected and passing traffic. Please edit your question to add: modinfo e1000e | grep version and also: ping -c3 www.google.com and also: dmesg | grep e100 If the outcome is sizable, post here and give us the link: paste.ubuntu.com –  chili555 Feb 19 at 14:47
    
hi chili555, full output of modinfo, ping and more is here: paste.ubuntu.com/6960350 thanks. –  Scotv Feb 19 at 15:15
    
hi chili555, from a string of ping output in Ubuntu: PING www.google.com (192.168.0.1) 56(84) bytes of data., Is there any issue with DNS? When I reboot into windows, I got Pinging www.google.com [173.194.38.136] with 32 bytes of data: –  Scotv Feb 19 at 15:27
    
It sure seems like a DNS issue, however, nm-tool reports the same details as Windows! Please paste the same way: cat /etc/resolv.conf and also: cat /etc/hosts and also: ping -c3 173.194.38.136. Something simple has gone astray and we'll find and fix it. –  chili555 Feb 19 at 21:06
    
hi chili555, it seems my network is not stable in Ubuntu. This is a bash output when network is good today, this is oupout when network didn't work minutes ago. Network didn't work during past days, and just switched between good and bad in Ubuntu today. But in Windows, network seems stable. –  Scotv Feb 20 at 13:42

1 Answer 1

up vote 2 down vote accepted

Did you notice that when the internet connection is not working correctly, that you have both a wired and wireless connection? Network Manager is supposed to disallow this. As well, your system will struggle to decide which connection to use and what traffic goes where unless it is directed manually such as in /etc/network/interfaces. Typically, a home user needn't use this level of complication.

Please switch the wireless off and tell us if your ethernet operates as expected.

If this is a stay-at-home computer that is always attached to ethernet, we can blacklist the wireless driver so it never tries to interfere.

Please remove all edits to Network Manager, select Automatic (DHCP) and reboot. Reboot the router as well. Do you get an IP address? Please pastebin again. I suspect that setting a static IP address in Ubuntu that is the same as a dynamic IP in Windows is causing the router a problem.

share|improve this answer
    
hi chili555, I have turned off my wireless, but it still not stable in Ubuntu, here is bash output when network was ok, and here is output when network was broken. –  Scotv Feb 22 at 15:20
    
Please see my edit. –  chili555 Feb 22 at 15:54
    
thanks, I remove all IP manual setting, the network becomes more stable now, at least, it can work sometimes. However, when the network stop working, I have to disable network and enable it again. –  Scotv Mar 9 at 8:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.