Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Kubuntu 13.10 with a Bose Mini Soundlink. I have no issue discovering, pairing and trusting the external speaker. On the contrary, I'm having great troubles in streaming the sound from the computer directly to the speaker via the Audio Sink feature.

Each time it times out and/or returns a "Stream Setup Failed" error. I tried with the default Bluetooth manager as well as with the BlueDevil KDE Bluetooth stack but no luck so far.

Here's what dmesg says:

$ dmesg | grep -i blue
[    5.484915] Bluetooth: Core ver 2.16
[    5.484938] Bluetooth: HCI device and connection manager initialized
[    5.484944] Bluetooth: HCI socket layer initialized
[    5.484945] Bluetooth: L2CAP socket layer initialized
[    5.484957] Bluetooth: SCO socket layer initialized
[    5.487753] Bluetooth: RFCOMM TTY layer initialized
[    5.487762] Bluetooth: RFCOMM socket layer initialized
[    5.487763] Bluetooth: RFCOMM ver 1.11
[    5.523001] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.523004] Bluetooth: BNEP filters: protocol multicast
[    5.523012] Bluetooth: BNEP socket layer initialized
[21576.258783] Bluetooth: Wrong link type (-14)
[21576.260000] Bluetooth: Wrong link type (-2)

Have you been able to get this working (on any *buntu) and if yes, how did you make it work?

share|improve this question
    
I do pulseaudio-module-bluetooth 1:4.0-0ubuntu6 and pulseaudio-module-gconf 1:4.0-0ubuntu6 –  anavarre Feb 20 at 8:25

2 Answers 2

I am using ubuntu 12.04 but I also had problems with my bluetooth headset. I am using blueman right now and it works fine.

sudo apt-get install blueman

You will be having two bluetooth symbols on your bar but hopefully it will work. Sometimes to connect properly you need to use 'Refresh services' under the menu. Hope it helps.

share|improve this answer
    
Thanks, but I do have blueman already (1.23+update1-2ubuntu1) and it didn't make any difference, unfortunately. –  anavarre Feb 26 at 10:33

I thing that solved my problem was to connect to headset service. Then under pulseaudio control the audio sink was exposed. also under /etc/bluetooth/audio.conf I set:

HFP=false 

and uncommented

#[A2DP]
SBCSources=1
MPEG12Sources=0

Then under pulse audio I was able to disable the sound card and switch the profile to A2DP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.