Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is output of ls -l of the file.

?????????? ? ? ? ? ? Es0g00og0QEX-psLsdocmdfj9skdL (Filename is Red color)

It's a file in /fscache/cache under /data of my Ubuntu home station. I used root user to delete it, change its permission and everything I could think about, but it doesn't work and shown "No such file or directory" Error.

Is there anyone know how to delete this kind of file?

Additional info:

Results of mount -v |grep data

/dev/md4 on /data type xfs (rw)

Results of fdisk -l |grep /dev/sda4

Disk /dev/md4 doesn't contain a valid partition table

/dev/sda4  101713920 312581807 105433933  fd linux raid autodetect`
share|improve this question
    
That means you have read permission in the directory but you cannot perform stat on file. What are your permissions on the directory? Have you tried sudo? –  Wtower Feb 19 at 10:58
1  
Why do you need to delete a file from /data? –  ZDroid Feb 19 at 10:58
    
What about sudo ls -l? You can also try using srm. –  Wilf Feb 19 at 10:59
    
@rusty I need to delete them because I need more space in /data for my new project. /data is the partition that I created while I was installing Ubuntu on my laptop. And I tried sudo rm -f already but can't delete it. –  inwwayu Feb 19 at 11:22
    
It could be the filesystem ownership for the partition that's mounted to your /data directory, check the ownership and permissions with ls -ld /data.. and if that actually is the issue, make appropriate ownership/permission changes for file and directories with chown and chmod or you could just make changes for fmask and dmask values along with editing the mount options for the partition in /etc/fstab file.. These links should help: Fstab, AutomaticallyMountPartitions –  precise Feb 19 at 13:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.