Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've successfully deployed OpenStack Havana using Juju over Ubuntu precise. Each charm on dedicated server and everything looks normal.

When I tried to access horizon, I get the login page and successfully authenticate, then I get 500 Internal Server Error.

I checked /var/log/apache2/error.log and found the first portion of this: http://pastebin.ubuntu.com/6957430/

After some googling I followed the instructions on this thread (https://bugs.launchpad.net/ubuntu/+source/libapache2-mod-python/+bug/1073147), yet I still couldn't access horizon and found the second portion on the pastebin log file.

Then lastly I tried sudo a2dismod deflate to change the logging mode, so I found the third portion on the log file.

Now the status of horizon charm is 1 hook failed "config-changed" and I still cannot access it.

This is my juju status output: http://pastebin.ubuntu.com/6957440/

Please help, Thank you

share|improve this question

closed as off-topic by fossfreedom Apr 30 at 21:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – fossfreedom
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Now horizon charm is up and ok, and when I try to open it from browser I get 404 error. pastebin.ubuntu.com/6959644 –  Harti Feb 19 at 12:20
    
Can you please paste the horizon/0 unit log into the question, so the exact steps leading to the config-changed hook failing can be traced? You get the log by running: juju scp horizon/0:/var/log/juju/unit-horizon-0.log ~/ –  dimitern Feb 21 at 12:27
    
This question hasn't been updated in a while and is using an so I'm going to vote to close it. If this is still an issue please try with Juju 1.18+ and update your question, thanks! –  Jorge Castro Apr 30 at 20:54