Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have what seems to be an odd anomaly on my hands. I'm trying to run Ubuntu 12.04 LTS on my 2010 MacBook Pro. I'd like to run it externally. I used my desktop installation of 12.04 and my 12.04 LTS installation DVD to create a ubuntu start-up disk on an 8GB flash drive. I tested it by booting my MacBook Pro while holding the option key. The usb drive shows up as an EFI boot and boots without a hitch when I choose "try Ubuntu without installing." After confirming that this worked, I assumed a full install of Ubuntu 12.04 on an external HDD would work just as well. Apparently, this isn't true. Using the same boot method, the laptop fails to locate the external drive with Ubuntu 12.04 on it.

Any thoughts? I've wondered if this is an EFI/Grub2 problem, as the 8GB start-up disk has some boot files that I can't find on the full installation on my external drive.

Additionally, I'm sure rEFIt will get mentioned if anyone responds here. I installed it in OSX Lion months ago; however, my internal HDD appears to be dead, hence why I'm trying to get Ubuntu running on the laptop. In short, I do not have a functioning copy of OSX at the moment. Could this be as simple as dragging/dropping EFI boot files from one disk to another?

Thanks.

share|improve this question
    
When you installed Ubuntu on the external hdd, where did you install grub? The default is the internal hdd, so if your internal hdd is still visible in the list of disks and you did not manually choose the external disk for Grub, chances are that Grub was installed on the internal drive. –  To Do Feb 18 at 21:14
    
I believe I installed Grub to the external disk - I remember selecting it as the install location for the bootloader. Or I think I did, at least. /boot/grub is on the external HDD, but certain files on the startup disk, such as x86_64-efi are absent. The startup disk also has a file titled EFI in the main directory. –  user249678 Feb 18 at 22:35
    
Just to be a sure, I did a manual reinstall of grub onto my external HDD, but with no change in results. –  user249678 Feb 19 at 8:23

1 Answer 1

I think that Boot Repair can help.

Boot Ubuntu from a LiveCD or Live USB and connect to the internet.

Make sure the external hard disk is connected.

Open a terminal, and add the Boot Repair PPA

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

Install Boot Repair

sudo apt-get install -y boot-repair && boot-repair

Select recommended repair, see https://help.ubuntu.com/community/Boot-Repair#Using_Boot-Repair for more details

share|improve this answer
    
I installed and ran Boot Repair, still with no success, but one message the Boot Repair prompted me with seems important: –  user249678 Feb 20 at 5:28
    
"The boot of your PC is in EFI mode, but no EFI partition was detected. You may want to retry after creating a EFI partition (FAT32, 100MB-250MB, start of the disk, boot flag). Do you want to continue?" –  user249678 Feb 20 at 5:31
    
I'm up to try that, but I'm not wholly sure how to proceed. Creating a 250 MB FAT32 partition? Got it. Start of the disc and boot flag? I'm not sure exactly how to do what it's suggesting. Any thoughts? –  user249678 Feb 20 at 5:33
    
One final note - I know that Macs use a GUID partition table out of the box, and I did a Master Boot Record install on my external drive. I'm not sure if that will make any kind of difference here. –  user249678 Feb 20 at 5:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.