Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've decided to make a wallet trough Armory so I can transfer Bitcoins to cold storage, so I went to install Armory.

Now, Armory installed all well and good and than asked me to install PPAs, which I followed the install procedure. Then I got an error.

I was saying that qt4 based programs are needed along with python-qt4 for armory, the dependencies. Now I tried this to resolve them:

sudo apt-get check

This is what I get:

lipovi@lipovi:~$ sudo apt-get check
[sudo] password for lipovi: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:

libqt4-designer : Depends: libqt4-script (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
Depends: libqt4-xml (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed

libqt4-dev : Depends: libqt4-designer (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.4 is installed
Depends: libqt4-help (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.4 is installed
Depends: libqt4-scripttools (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.4 is installed
Depends: libqt4-test (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.4 is installed

libqt4-help : Depends: libqt4-network (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is     installed
Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed

libqt4-qt3support : Depends: libqt4-designer (= 4:4.8.1-0ubuntu4.6) but     4:4.8.1-0ubuntu4.4 is installed

libqt4-scripttools : Depends: libqt4-script (= 4:4.8.1-0ubuntu4.4) but     4:4.8.1-0ubuntu4.6 is installed
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed

libqt4-test : Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.6 is installed
E: Unmet dependencies. Try using -f.

Then I tried this:

sudo apt-get -f install

This is what it prints out:

lipovi@lipovi:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqt4-designer libqt4-help libqt4-scripttools libqt4-test
The following packages will be upgraded:
  libqt4-designer libqt4-help libqt4-scripttools libqt4-test
4 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
6 not fully installed or removed.
Need to get 0 B/4,155 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of libqt4-designer:
 libqt4-designer depends on libqt4-script (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-script on system is 4:4.8.1-0ubuntu4.6.
 libqt4-designer depends on libqt4-xml (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-xml on system is 4:4.8.1-0ubuntu4.6.
 libqt4-designer depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
 libqt4-designer depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtgui4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-designer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:
 libqt4-help depends on libqt4-network (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-network on system is 4:4.8.1-0ubuntu4.6.
 libqt4-help depends on libqt4-sql (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-sql on system is 4:4.8.1-0ubuntu4.6.
 libqt4-help depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
 libqt4-help depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtgui4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-help (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:
 libqt4-scripttools depends on libqt4-script (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-script on system isNo apport report written because the error     message indicates its a followup error from a previous failure.
                                                                 No apport report     written because the error message indicates its a followup error from a     previous failure.
           No apport report written because the error message indicates its a     followup error from a previous failure.
                                     No apport report written because the error     message indicates its a followup error from a previous failure.
                                                               No apport report     written because the error message indicates its a followup error from a previous failure.
         No apport report written because the error message indicates its a followup     error from a previous failure.
                                    4:4.8.1-0ubuntu4.6.
 libqt4-scripttools depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
 libqt4-scripttools depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtgui4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-scripttools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:
 libqt4-test depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-test (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-qt4:
 python-qt4 depends on libqt4-designer (>= 4:4.8.0-1~); however:
  Package libqt4-designer is not configured yet.
 python-qt4 depends on libqt4-help (>= 4:4.8.0-1~); however:
  Package libqt4-help is not configured yet.
 python-qt4 depends on libqt4-scripttools (>= 4:4.8.0-1~); however:
  Package libqt4-scripttools is not configured yet.
 python-qt4 depends on libqt4-test (>= 4:4.8.0-1~); however:
  Package libqt4-test is not configured yet.
dpkg: error processing python-qt4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of armory:
 armory depends on python-qt4; however:
  Package python-qt4 is not configured yet.
dpkg: error processing armory (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqt4-designer
 libqt4-help
 libqt4-scripttools
 libqt4-test
 python-qt4
 armory
E: Sub-process /usr/bin/dpkg returned an error code (1)

And after the previous command, this:

sudo apt-get install -f

It prints almost the same thing.

I tried too:

sudo dpkg --configure -a

The print out is this:

lipovi@lipovi:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libqt4-designer:
 libqt4-designer depends on libqt4-script (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-script on system is 4:4.8.1-0ubuntu4.6.
 libqt4-designer depends on libqt4-xml (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-xml on system is 4:4.8.1-0ubuntu4.6.
 libqt4-designer depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
 libqt4-designer depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtgui4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-designer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:
 libqt4-help depends on libqt4-network (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-network on system is 4:4.8.1-0ubuntu4.6.
 libqt4-help depends on libqt4-sql (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-sql on system is 4:4.8.1-0ubuntu4.6.
 libqt4-help depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
 libqt4-help depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtgui4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-help (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:
 libqt4-scripttools depends on libqt4-script (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqt4-script on system is 4:4.8.1-0ubuntu4.6.
 libqt4-scripttools depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
 libqt4-scripttools depends on libqtgui4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtgui4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-scripttools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-qt4:
 python-qt4 depends on libqt4-designer (>= 4:4.8.0-1~); however:
  Package libqt4-designer is not configured yet.
 python-qt4 depends on libqt4-help (>= 4:4.8.0-1~); however:
  Package libqt4-help is not configured yet.
 python-qt4 depends on libqt4-scripttools (>= 4:4.8.0-1~); however:
  Package libqt4-scripttools is not configured yet.
dpkg: error processing python-qt4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-test:
 libqt4-test depends on libqtcore4 (= 4:4.8.1-0ubuntu4.4); however:
  Version of libqtcore4 on system is 4:4.8.1-0ubuntu4.6.
dpkg: error processing libqt4-test (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of armory:
 armory depends on python-qt4; however:
  Package python-qt4 is not configured yet.
dpkg: error processing armory (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqt4-designer
 libqt4-help
 libqt4-scripttools
 python-qt4
 libqt4-test
 armory

Whatever I do, it won't resolve it.

Now, I would really nicely ask if someone had this problem and, by chance, offer a solution, I'd be really grateful.

The coins are on my phone I would like to move them as soon as possible from it.

P.S. Don't ask for them......

share|improve this question
    
1) What version of Ubuntu are you running 2) How did you install Armory? –  bigbadonk420 Feb 18 at 16:26
    
1) Ubuntu 12.04 2) Went to the Armory website, downloaded tar.gz, un-packed it and followed the installation instructions on the website. –  lipovi Feb 18 at 16:34
    
Why did you download the tar.gz instead of the .deb files for 12.04? bitcoinarmory.com/download –  bigbadonk420 Feb 18 at 16:39
    
That's the site I've downloaded the packed .deb files. They are all in that tar.gz file. –  lipovi Feb 18 at 17:02
    
There are tar.gz files under the Linux logo (Tux, the penguin), and under the Ubuntu logo there are DEB-files. I suspect you downloaded the tar.gz files without really having to, making this unnecessarily complicated. Anyway, I see you have resolved this by reinstalling the packages :) –  bigbadonk420 Feb 19 at 7:54

1 Answer 1

up vote 1 down vote accepted

Try the below commands on terminal to force remove all the unconfigured packages,

sudo dpkg -P --force-all --force-remove-reinstreq libqt4-designer
sudo dpkg -P --force-all --force-remove-reinstreq libqt4-help
sudo dpkg -P --force-all --force-remove-reinstreq libqt4-scripttools
sudo dpkg -P --force-all --force-remove-reinstreq libqt4-test
sudo dpkg -P --force-all --force-remove-reinstreq python-qt4
sudo dpkg -P --force-all --force-remove-reinstreq armory

Then try to install all the packages via apt-get,

sudo apt-get install libqt4-designer
sudo apt-get install libqt4-help
sudo apt-get install libqt4-scripttools
sudo apt-get install libqt4-test
sudo apt-get install python-qt4
sudo apt-get install armory
share|improve this answer
1  
This worked like a charm! No dependencies left, now I can install Armory again without being blocked by something missing. You're a life saver, man! –  lipovi Feb 18 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.