Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When I open my Firefox Web Browser from the terminal I get these following warnings.

william@william-AO722:~$ firefox
(process:5672): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
(firefox:5672): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised
(firefox:5672): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised
(firefox:5672): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised
(firefox:5672): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

Is there a way that I can get rid of these warnings?

Also can anyone tell me what GLib is and what is it for?

I am running Ubuntu 13.10

share|improve this question

marked as duplicate by BuZZ-dEE, i08in, Seth, Eric Carvalho, Ask Feb 19 at 4:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
you can just ignore warnings, as long as the program doesn't crash or give errors you're fine. –  Alvar Feb 18 at 5:29
    
Other than getting the warnings, everything seems to run fine. I guess I can just ignore them for now. –  Willoczy Feb 18 at 6:27

3 Answers 3

up vote 1 down vote accepted

Your question is closely related to Why are there so many console messages from GTK+ applications?.

For the specific GLib error with Firefox please see https://bugzilla.mozilla.org/show_bug.cgi?id=833117.

To know how to disable these errors look at Disable css warnings and this answer: http://askubuntu.com/a/198385/248158 which suggests "redirecting stderr to /dev/null".

share|improve this answer

I think those is not warnings for you as an end user. It's just some messages passed to developers or some users that really want to know what is happening:).

Anyway what you need to do is just run your applications in background by inserting & at the end of your command and you'll not see such messages.You can try:

firefox &
share|improve this answer
    
Putting & at the end still shows the console output. You need >/dev/null 2>&1 to fully suppress output. –  minerz029 Feb 18 at 10:28

You don't have to care about these developer messages and warning.

You as a user should open the GTK application (like firefox) without redirecting messages to terminal window like so:

nohup firefox &
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.