Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All of a sudden i am unable to login into my user account. I have activated root account and i am able to login into that root account, however i cant able to login into my user account. I am very sure it is not a password error. When i login into my user account the screen flickers and again it is showing the login screen. Some times a popup appears in the top right corner as you see below. Can anyone help me to solve this problem ? i have posted this same question in ubuntuforums also but still no solutions helped me. I hope someone here will solve this issue.

Error

share|improve this question
    
The popup is too small to read anything. Can your home-partition be full? –  user unknown May 12 '11 at 13:53
1  
Can you login at the console? Hit Ctrl+Alt+F1 to get a console prompt. Then,try logging in as your regular user. That'll help us narrow things down. Also, have a look at ~/.xsession-errors and /var/log/Xorg.0.log (if you can log in from the console). Post anything that might be relevant. –  Scott Severance May 12 '11 at 14:52
    
For the first command i don get any output and for the second command "No such file or directory" –  karthick87 May 14 '11 at 10:04
    
By "no output," do you mean that ~/.xsession-errors exists but is empty? And have a look at the directory to see if perhaps the name of Xorg.log is different on your machine: ls /var/log/X*. –  Scott Severance May 16 '11 at 11:58
    
Drop to a TTY (Ctrl-Alt-F1) then login, then run sudo dpkg --configure -a - that's fixed this issue in the past for me. –  jrg May 16 '11 at 16:05
add comment

1 Answer

up vote 3 down vote accepted

This is more a workaround than a solution, since a solution isn't possible until we know what the problem is (hence the troubleshooting questions I've asked above).

Clearly, some of your settings are corrupted. Try doing this from a console (Ctrl+Alt+F1):

mkdir configuration_backup

# Get rid of any possible dotfiles that might cause trouble. You
# might not have all of these, and you might need to modify this
# list a bit. The files/directories will go to the newly-created
# configuration_backup directory so you can restore them if
# appropriate.
mv .config .dbus .gconf* .gnome* .gtk* .local .metacity configuration_backup

After this, you should be able to log in graphically. However, these steps will destroy many of your settings (unless you restore everything from configuration_backup. You'll have to redo them. If you can provide more details about your situation, there might be a solution that won't destroy your settings. Or, it might be easier to just accept this workaround and simply redo your settings.

If you later decide you want to restore your settings, look in the backup directory (~/configuration_backup) and find the name of the file or directory you want to restore. If you can't see what you want, use ls -A (command line) or Ctrl+H (Nautilus) to see the hidden files. I recommend that you first backup and delete the file/folder of the same name in your home directory. Then, copy one file/folder at a time to your home directory (e.g., cp -a ~/configuration_backup/.config ~), logging out and back in each time to make sure your old config files don't break your system.

share|improve this answer
    
Where i have to move this file configuration_backup –  karthick87 May 16 '11 at 12:14
    
@karthick87: It's a folder, not a file. You can put it anywhere. The point is to get those dotfiles out of your home directory. You could even delete your dotfiles, but deleting them removes the option of restoring them if your problem isn't solved. With the dotfiles gone, then the programs that use them will create new ones with default settings. Hopefully, then you'll be able to log in. –  Scott Severance May 16 '11 at 14:17
    
I dont want to loss my existing softwares and files. Any other way ? –  karthick87 May 16 '11 at 15:06
    
@karthick87: You won't lose your software and data files. You'll only lose your settings. There's no other way I know to tell you unless we can figure out what the real problem is. Since you haven't provided the troubleshooting information I asked for above, I can't help you any further on that front until you provide more information. –  Scott Severance May 17 '11 at 5:36
1  
Thanks, this helped to fix my issue as well. –  Honoki May 18 '12 at 8:18
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.