Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm facing an issue on Ubuntu 12.04 with Nouveau after complete removal of the Nvidia driver. I did this for removal:

sudo apt-get remove --purge nvidia-*
sudo rm /etc/X11/xorg.conf
sudo apt-get install ubuntu-desktop
echo 'nouveau' | sudo tee -a /etc/modules

and everything seemed to work fine. But when I start music player, open web browser and search through folders in Nautilus I get kick off to this screen:

enter image description here

share|improve this question

closed as off-topic by bodhi.zazen, BuZZ-dEE, LnxSlck, Olli, Braiam Feb 18 at 23:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bodhi.zazen, BuZZ-dEE, LnxSlck, Olli, Braiam
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I edited some system settings and it works for now I'll provide an answer if it really keep working. –  JohnnyEnglish Feb 17 at 20:19

1 Answer 1

ok then so I managed to avoid this problem to get hanged and kick off to that screen as the one in the screenshot. Seems to be the cause was in speech-dispatcher after I ran:

sudo update-rc.d -f speech-dispatcher remove

which removed it from auto start/shutdown and also I restarted Display Manager:

sudo /etc/init.d/lightdm restart

And since then, after repeating all those actions that led to this problem doesn't seem to happen anymore.

A little adjustment to the answer also provided by me: Cannot stop or restart Display Manager due to Java misconfiguration in 12.04 helps to get rid off annoying jetty.

share|improve this answer
    
You should probably report this as a bug. –  Seth Feb 18 at 21:34
    
well yes I guess you are right I just rolled back to Nvidia after trying hard to make it 100% work but still Nvidia took up for me. –  JohnnyEnglish Feb 19 at 18:29
    
If you find a bug for this (or report one) make sure to add your workaround :) –  Seth Feb 19 at 18:37
    
all workaround I could achieve is provided in my answer with a link to other question and it works actually good! but the only problem remained I couldn't fix manual restart of lightdm only by stopping and starting it again somebody told me it's a bug so I left it :) –  JohnnyEnglish Feb 19 at 18:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.