Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04 64bit guest with Windows 7 64-bit host. I do have 3D Acceleration enabled in Virtualbox settings.

Every time I enable visual effects in Ubuntu the Virtualbox GUI crashes. What do I need to do to have visual effects enabled in Ubuntu? Virtualbox's logs don't say anything useful at crash.

My graphics card is an Nvidia 8800 GTS with the latest 258.96 drivers, but I'm sure that's not part of the issue.

share|improve this question

closed as off-topic by bain, Eric Carvalho, Sneetsher, Lekensteyn, bodhi.zazen Jun 30 at 18:53

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers 3

Inside the guest, install the package virtualbox-ose-guest-x11 and restart the VM; that may resolve the issue. X on the guest needs to be aware of the VirtualBox drivers, and as far as I know this is the way to go about that. Versions 2.2 and up should make this functionality seamless, but it's possible there are some bugs in there.

Also, be sure you've allocated plenty of video memory in the VM settings. I gave it a go just now with 128 MB VRAM (which might be excessive) and it worked fine after installing the -x11 package I mentioned. Start high if you can and lower it if you need to until it stops working.

share|improve this answer
    
Just gave this a shot, nothing has improved. I noticed that the Guest Additions that comes with Virtualbox is newer than the virtualbox-ose-guest-x11 package as well. –  Derek Sep 16 '10 at 4:38

I thought the 2D and 3D acceleration support for guests was only in the PUEL edition of VirtualBox, and not in the OSE version. (I'm likely wrong about this, I'm much more familiar with the PUEL, not with OSE version of VirtualBox.)

Either way, I'd install the guest additions that come with your exact edition/version of VirtualBox, not what happens to be in Synaptic. Click on Devices->Intall Guest Additions. Once you click on Devices->Install Guest Additions, if that doesn't make the VBox CD image available on your guest desktop, reboot the guest. Once the guest additions show up, here is how I install them:

sudo /media/VBOXADDITIONS_3.2.10_66523/VBoxLinuxAdditions-amd64.run 

If your guest is running the 32-bit version of Ubuntu, you'd instead run the following:

sudo /media/VBOXADDITIONS_3.2.10_66523/VBoxLinuxAdditions-x86.run 

...followed by a reboot of the guest.

share|improve this answer

First start the Terminal and then run these commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install dkms build-essentials

Now Restart your system.

Install Guest Editions in the OS by clicking on Devices-->Install Guest Additions in the VirtualBox menubar of the running virtual machine.

Restart again.

Try turning on extra desktop effects in Appearance Settings

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.