Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a Sony VAIO F series (SVF15A1C5E) recently with Windows 8 on it. I installed Ubuntu 12.04 and just kept a recovery partition for Windows as I do not need it. Unfortunately I cannot connect to the Internet either wired or wireless. I have seen and read the similar topic and tried most of the answers unsuccessfully (I might have done something wrong when applying the answer to my case though) I also asked my department IT but they could not solve it.

The output of lshw -C network is:

*-network  
   description: Network controller  
   product: BCM43142 802.11b/g/n  
   vendor: Broadcom Corporation  
   physical id: 0  
   bus info: pci@0000:07:00.0  
   version:01  
   width: 64 bits  
   clock: 33MHz  
   capabilities: pm msi pciexpress bus_master cap_list  
   configuration: driver=bcma-pci-bridge latency=0  
   resources: irq:16 memory:d1700000-d1707fff  

*-network  
   description: Ethernet interface  
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller  
   vendor: Realtek Semiconductor Co., Ltd.  
   physical id: 0  
   bus info: pci@0000:0e:00.0  
   logical name: eth0  
   version: 0c  
   serial:78:84:3c:3a:cd:7d  
   size: 10Mbit/s  
   clock: 33MHz  
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation  
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8169g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s  
resources: irq:46 ioport:2000(size=256) memory:d1500000-d1500fff memory:d1400000-d1403fff  

I also edited /etc/NetworkManager/NetworkManager.conf so that managed=TRUE while it was =FALSE. Any suggestions?

share|improve this question
    
Do you still have your Ubuntu 12.04 install DVD or USB? –  chili555 Feb 17 at 16:04
    
Yes I still have the install on a USB –  cenzo Feb 17 at 16:42

1 Answer 1

up vote 1 down vote accepted

I believe the package you need is on the install USB. Please insert the USB and when the file manager opens with the contents of the USB, select pool > restricted > b > bcmwl > bcmwl-kernel-source > bcmwl-kernel-source-xxx.deb. Right-click it and select 'Open with Ubuntu Software Center.' After it installs, your wireless should be working. It may take a reboot.

If it complains about the dkms package, it is also on the USB at pool > main > d > dkms > dkms-xxx.deb. You might try installing it first and then bcmwl-kernel-source. You should be trying to install the deb files within, not the entire directory.

If you cannot install either from the USB, drag and drop the deb files to your desktop and do:

cd ~/Desktop
sudo dpkg -i *.deb
share|improve this answer
    
thanks for helping! I tried it but I needed to install the dkms package first. I tried to install it using a separate usb but I cannot install anything through the ubuntu software center as the install button is frozen (I can't click on it) I tried to do it from the terminal using sudo software-center but I was no more lucky, it looks to me as the usc needs connexion to the internet to install the package. I followed the comments in this question as well as the there-linked pages but I am still unsuccessfull. –  cenzo Feb 18 at 12:41
    
Please see my edit. –  chili555 Feb 18 at 15:01
    
I had just come across using dpkg -i when you edited your post! this worked very well, thanks again. –  cenzo Feb 18 at 16:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.