Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am trying to setup build environment on Ubuntu 12.04 (precise)(64bit). I am following the guide at official android site. I encountered the following message.

$ sudo apt-get install  libgl1-mesa-dev
[sudo] password for buddy: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dev : Depends: mesa-common-dev (= 9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt~precise)
                   Depends: libdrm-dev (>= 2.4.45)
E: Unable to correct problems, you have held broken packages.

I tried installing mesa-common-dev

$ sudo apt-get install  mesa-common-dev

message

The following packages have unmet dependencies:
 mesa-common-dev : Depends: libdrm-dev (>= 2.4.45)

Then I tried installing

 $ sudo apt-get install libdrm-dev

message

The following packages have unmet dependencies:
 libdrm-dev : Depends: libdrm2 (= 2.4.46-1ubuntu0.0.0.1) but 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~precise is to be installed
              Depends: libdrm-intel1 (= 2.4.46-1ubuntu0.0.0.1) but 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~precise is to be installed
              Depends: libdrm-radeon1 (= 2.4.46-1ubuntu0.0.0.1) but 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~precise is to be installed
              Depends: libdrm-nouveau1a (= 2.4.46-1ubuntu0.0.0.1) but 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~precise is to be installed
              Depends: libdrm-nouveau2 (= 2.4.46-1ubuntu0.0.0.1) but 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~precise is to be installed
              Depends: libkms1 (= 2.4.46-1ubuntu0.0.0.1) but 2.4.46+git20130702.c6d73cfe-0ubuntu0sarvatt~precise is to be installed
E: Unable to correct problems, you have held broken packages.

Then I tried the following steps mentioned here: How do I resolve unmet dependencies? skipping the Disable/Remove/Purge PPAs part.

share|improve this question

marked as duplicate by karel, Eric Carvalho, Avinash Raj, BuZZ-dEE, Seth Feb 19 at 19:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Disable that PPA ... the version numbers indicate these are not Ubuntu archive packages ...

share|improve this answer
1  
Can you please add steps to your answer. How to do that in my case and which ppa? –  Sunny Kumar Aditya Feb 18 at 10:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.