Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting the 'unsupported locale setting' error as referenced here (on Ubuntu 13.10). However, following Martijn suggestion only fixes the problem temporarily. Opening a new bash reverts to the 'unsupported locale' problem. Any ideas how I can fix this permanently?

share|improve this question

1 Answer 1

If you are on an Ubuntu desktop, use System Settings -> Language Support.

Otherwise you may want to study a general guide on setting environment variables persistently in Ubuntu.

share|improve this answer
    
I've narrowed the required settings to only the "export LC_ALL=en_US.UTF-8". However, I've read the general guide, and still not sure where I should put it. I have it in the .bashrc file, and it works. But I feel it's a work-around. –  Roee E Feb 19 at 9:06
    
Assuming it's a server you have, add to /etc/default/locale the line LANG=en_US.UTF-8 (without the export). Setting LC_ALL persistently like that is usually not a good idea. –  Gunnar Hjalmarsson Feb 19 at 18:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.