Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sorry for my bad grammar, but i need help to install new ubuntu on my PC.
I've a Lenovo Z570 Laptop with following specs:

Intel i5 2430M
4 GB RAM
Nvidia 520M (optimus) - switchable with Intel HD 3000
750 GB HDD

I've installed windows 8 in Legacy BIOS mode as PC doesn't support UEFI. When I try to install Ubuntu 13.10, it tries to install in EFI mode i.e. boot screen - black and with a error message first

Couldn't open '\EFI\BOOT\fallback.efi':14

After configuring the installation, installation fails at last step with the following message:

grub-efi-amd64-signed failed to install into /target/

Does anyone have the same problem? What should I do now ?

Extra info:
GNU Parted output (sudo parted -l)

Model: ATA WDC WD7500BPVT-2 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  65.8GB  65.8GB  primary   ntfs            boot
 2      686GB   690GB   4201MB  extended
 5      686GB   690GB   4201MB  logical   linux-swap(v1)
 3      690GB   750GB   60.2GB  primary   ext4
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Your observation that

When I try to install Ubuntu 13.10, it tries to install in EFI mode i.e. (Boot screen - black and with a error message first "Couldn't open '\EFI\BOOT\fallback.efi':14 " )

...clearly belies your earlier claim that the computer doesn't support EFI. You can't get that message unless the computer is booting in EFI mode. It's possible that the documentation doesn't mention it, or the support may have been added in a firmware update after the documentation was written, but you've clearly got an EFI in the computer.

That said, your partition table data also clearly indicates that you've got a BIOS/CSM/legacy-mode installation of Windows, and the best way to get Linux to coexist with that is to boot Linux in BIOS/CSM/legacy mode. Chances are you can do this by using your firmware's built-in boot manager to select the boot option for your boot medium that does not include the string "EFI" or "UEFI." (You can usually access the boot manager by hitting Esc or a function key very early in the boot process. Unfortunately, which key varies from one computer to another.) On an EFI-based computer, you'll often see two options for removable medium, one with the string "EFI" or "UEFI" and the other without; just select the one without that string to boot in BIOS/CSM/legacy mode.

If that doesn't work, try mounting your USB installer and removing the entire EFI directory tree from it. (This is theoretically possible if you're using a CD-R or DVD-R, but it's much harder because you'd need to remaster it.) The EFI boot loader resides in this directory, so without an EFI boot loader, the computer will be forced to boot the installer in BIOS/CSM/legacy mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.