Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 13.10 on a new computer I put together however I am unable to get my Ethernet to work. What happens is my computer will go through phases of searching for a network and then occasionally pop a red box that says you are disconnected from the network.

here are the results of my ifconfig:

eth1      Link encap:Ethernet  HWaddr 74:d4:35:58:b2:47  
          inet6 addr: fe80::76d4:35ff:fe58:b247/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:713 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:1034 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:53473 (53.4 KB)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6272 (6.2 KB)  TX bytes:6272 (6.2 KB)

any help I can get would be greatly appreciated.

Thanks

EDIT:

after looking over my config I appear to have an ipv6 address. and I know for a fact that this particular network isn't configured to hand out ipv6 addresses (its a private home network)

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Ok so the issue I had was that I was using a realtek ethernet card which ubuntu has an issue with.

the directions I found here: http://ubuntuforums.org/showthread.php?t=1661489

they ALMOST worked. Others may have better luck with them.

In the end I just sprung for a usb to ethernet adapter that was compatible with my linux kernal and everything worked well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.