Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded from 13.04 to 13.10 today and everything works smooth apart from one thing. I have a dual monitor setup and every time reboot the screens have switched places (left screen on right monitor and vice versa). I have correctly created an xorg.conf which is shown below.

I have tried all the solutions which are suggested in theses two posts:

nvidia-settings lost after reboot

Nvidia drivers seem to ignore customized xorg.conf in 13.10? How to configure?

including checking for ~/.config/monitor.xml which I don't have. Loading the nvidia-setting at runtime using nvidia-settings -l which doesn't do anything. But that kinda makes sense to me since the .nvidia-setting-rc doesn't really have any info about screen positions. And since I'm running LXDE as my desktop environment "Preferences->Monitor Settings" is only concerned with screen resolution, not screen position.

Now here is the odd thing: When lightdm loads up the screens are initially in the correct order (as specified in the xorg.conf) and then switch order after a couple of secounds.

In my Xorg.0.log I found the following line

[    11.806] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +0+0, DVI-D-0: nvidia-auto-select @1680x1050 +1680+0"

which I believe could very well be the culprit. It seems as if the nvidia driver overrides the settings in xorg.conf after the fact even though I'm not starting nvidia-settings at startup as far as I know.

EDIT:

I just upgraded from nvidia-304 to nvidia-319 and now my suspicions a confirmed because the x-server boot log is now a little bit clearer. The relevant lines are:

[     6.460] (**) NVIDIA(0): Option "MetaModes" "CRT: nvidia-auto-select +1680+0, DFP: nvidia-auto-select +0+0"

Options are correctly read from xorg.conf

[     6.908] (II) NVIDIA(0): Setting mode "CRT:nvidia-auto-select+1680+0,DFP:nvidia-auto-select+0+0"

and correctly set

[    11.197] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-D-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
[    11.222] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-D-0: nvidia-auto-select @1680x1050 +1680+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"

and then later overridden by the nvidia driver for apparently no reason.

Any ideas anybody?

Any help would be much appreciated.

xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.88  (buildd@panlong)  Thu Jul 11 10:40:14 UTC 2013

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 650 Ti"
    Option         "nvidiaXineramaInfoOrder" "DFP-1, CRT-0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1, CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +1680+0, DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

EDIT 2:

What I found out is that the log message which signals the override of the xorg.conf settings is one that is caused by a call to xrandr (as I'm doing this myself from the commandline to set the screens in the correct order).

Below you'll find my x-server log file. Please be aware that the very last two entries at approx. 31.5 secs are caused by me calling xrandr from the commandline with the correct settings.


[     6.376] 
X.Org X Server 1.14.5
Release Date: 2013-12-12
[     6.376] X Protocol Version 11, Revision 0
[     6.376] Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
[     6.376] Current Operating System: Linux xyz 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:22:01 UTC 2014 x86_64
[     6.376] Kernel command line: BOOT_IMAGE=/vmlinuz-3.11.0-15-generic root=xyz ro splash quiet
[     6.376] Build Date: 17 December 2013  10:06:15AM
[     6.376] xorg-server 2:1.14.5-1ubuntu2~saucy1 (For technical support please see http://www.ubuntu.com/support) 
[     6.376] Current version of pixman: 0.30.2
[     6.376]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[     6.376] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     6.376] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 22 09:14:56 2014
[     6.376] (==) Using config file: "/etc/X11/xorg.conf"
[     6.376] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     6.376] (==) ServerLayout "Layout0"
[     6.377] (**) |-->Screen "Screen0" (0)
[     6.377] (**) |   |-->Monitor "Monitor0"
[     6.377] (**) |   |-->Device "Device0"
[     6.377] (**) |-->Input Device "Keyboard0"
[     6.377] (**) |-->Input Device "Mouse0"
[     6.377] (**) Option "Xinerama" "0"
[     6.377] (==) Automatically adding devices
[     6.377] (==) Automatically enabling devices
[     6.377] (==) Automatically adding GPU devices
[     6.377] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     6.377]    Entry deleted from font path.
[     6.377] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     6.377]    Entry deleted from font path.
[     6.377] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     6.377]    Entry deleted from font path.
[     6.377] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    built-ins
[     6.377] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[     6.377] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[     6.377] (WW) Disabling Keyboard0
[     6.377] (WW) Disabling Mouse0
[     6.377] (II) Loader magic: 0x7f752fd38d20
[     6.377] (II) Module ABI versions:
[     6.377]    X.Org ANSI C Emulation: 0.4
[     6.377]    X.Org Video Driver: 14.1
[     6.377]    X.Org XInput driver : 19.1
[     6.377]    X.Org Server Extension : 7.0
[     6.377] (II) xfree86: Adding drm device (/dev/dri/card0)
[     6.378] (--) PCI:*(0:1:0:0) 10de:11c6:10b0:11c6 rev 161, Mem @ 0xf6000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     6.378] (II) Open ACPI successful (/var/run/acpid.socket)
[     6.378] Initializing built-in extension Generic Event Extension
[     6.378] Initializing built-in extension SHAPE
[     6.378] Initializing built-in extension MIT-SHM
[     6.378] Initializing built-in extension XInputExtension
[     6.378] Initializing built-in extension XTEST
[     6.378] Initializing built-in extension BIG-REQUESTS
[     6.378] Initializing built-in extension SYNC
[     6.378] Initializing built-in extension XKEYBOARD
[     6.378] Initializing built-in extension XC-MISC
[     6.378] Initializing built-in extension SECURITY
[     6.378] Initializing built-in extension XINERAMA
[     6.378] Initializing built-in extension XFIXES
[     6.378] Initializing built-in extension RENDER
[     6.378] Initializing built-in extension RANDR
[     6.378] Initializing built-in extension COMPOSITE
[     6.378] Initializing built-in extension DAMAGE
[     6.378] Initializing built-in extension MIT-SCREEN-SAVER
[     6.378] Initializing built-in extension DOUBLE-BUFFER
[     6.378] Initializing built-in extension RECORD
[     6.378] Initializing built-in extension DPMS
[     6.378] Initializing built-in extension X-Resource
[     6.378] Initializing built-in extension XVideo
[     6.378] Initializing built-in extension XVideo-MotionCompensation
[     6.378] Initializing built-in extension SELinux
[     6.378] Initializing built-in extension XFree86-VidModeExtension
[     6.378] Initializing built-in extension XFree86-DGA
[     6.378] Initializing built-in extension XFree86-DRI
[     6.378] Initializing built-in extension DRI2
[     6.378] (II) "glx" will be loaded by default.
[     6.378] (WW) "xmir" is not to be loaded by default. Skipping.
[     6.378] (II) LoadModule: "dri2"
[     6.378] (II) Module "dri2" already built-in
[     6.378] (II) LoadModule: "glamoregl"
[     6.378] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[     6.494] (II) Module glamoregl: vendor="X.Org Foundation"
[     6.494]    compiled for 1.14.3, module version = 0.5.1
[     6.494]    ABI class: X.Org ANSI C Emulation, version 0.4
[     6.494] (II) LoadModule: "glx"
[     6.494] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[     6.533] (II) Module glx: vendor="NVIDIA Corporation"
[     6.534]    compiled for 4.0.2, module version = 1.0.0
[     6.534]    Module class: X.Org Server Extension
[     6.534] (II) NVIDIA GLX Module  319.32  Wed Jun 19 14:55:38 PDT 2013
[     6.534] Loading extension GLX
[     6.534] (II) LoadModule: "nvidia"
[     6.534] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[     6.539] (II) Module nvidia: vendor="NVIDIA Corporation"
[     6.539]    compiled for 4.0.2, module version = 1.0.0
[     6.539]    Module class: X.Org Video Driver
[     6.541] (II) NVIDIA dlloader X Driver  319.32  Wed Jun 19 14:34:12 PDT 2013
[     6.541] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     6.541] (++) using VT number 7

[     6.546] (II) Loading sub module "fb"
[     6.546] (II) LoadModule: "fb"
[     6.547] (II) Loading /usr/lib/xorg/modules/libfb.so
[     6.547] (II) Module fb: vendor="X.Org Foundation"
[     6.547]    compiled for 1.14.5, module version = 1.0.0
[     6.547]    ABI class: X.Org ANSI C Emulation, version 0.4
[     6.547] (WW) Unresolved symbol: fbGetGCPrivateKey
[     6.547] (II) Loading sub module "wfb"
[     6.547] (II) LoadModule: "wfb"
[     6.548] (II) Loading /usr/lib/xorg/modules/libwfb.so
[     6.548] (II) Module wfb: vendor="X.Org Foundation"
[     6.548]    compiled for 1.14.5, module version = 1.0.0
[     6.548]    ABI class: X.Org ANSI C Emulation, version 0.4
[     6.548] (II) Loading sub module "shadow"
[     6.548] (II) LoadModule: "shadow"
[     6.548] (II) Loading /usr/lib/xorg/modules/libshadow.so
[     6.549] (II) Module shadow: vendor="X.Org Foundation"
[     6.549]    compiled for 1.14.5, module version = 1.1.0
[     6.549]    ABI class: X.Org ANSI C Emulation, version 0.4
[     6.550] (II) Loading sub module "ramdac"
[     6.550] (II) LoadModule: "ramdac"
[     6.550] (II) Module "ramdac" already built-in
[     6.550] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[     6.550] (==) NVIDIA(0): RGB weight 888
[     6.550] (==) NVIDIA(0): Default visual is TrueColor
[     6.550] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[     6.550] (**) NVIDIA(0): Option "Stereo" "0"
[     6.550] (**) NVIDIA(0): Option "nvidiaXineramaInfoOrder" "DFP"
[     6.550] (**) NVIDIA(0): Stereo disabled by request
[     6.550] (**) NVIDIA(0): Option "MetaModes" "CRT: nvidia-auto-select +1680+0, DFP: nvidia-auto-select +0+0"
[     6.550] (**) NVIDIA(0): Enabling 2D acceleration
[     6.972] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (CRT-0)) does not support NVIDIA
[     6.972] (II) NVIDIA(GPU-0):     3D Vision stereo.
[     6.979] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 650 Ti (GK106) at PCI:1:0:0 (GPU-0)
[     6.979] (--) NVIDIA(0): Memory: 2097152 kBytes
[     6.979] (--) NVIDIA(0): VideoBIOS: 80.06.21.00.18
[     6.979] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     6.980] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 650 Ti at PCI:1:0:0
[     6.980] (--) NVIDIA(0):     Samsung SyncMaster (CRT-0) (boot, connected)
[     6.980] (--) NVIDIA(0):     DFP-0
[     6.981] (--) NVIDIA(0):     Samsung SyncMaster (DFP-1) (connected)
[     6.981] (--) NVIDIA(0): Samsung SyncMaster (CRT-0): 480.0 MHz maximum pixel clock
[     6.981] (--) NVIDIA(0): DFP-0: 165.0 MHz maximum pixel clock
[     6.981] (--) NVIDIA(0): DFP-0: Internal Single Link TMDS
[     6.981] (--) NVIDIA(0): Samsung SyncMaster (DFP-1): 330.0 MHz maximum pixel clock
[     6.981] (--) NVIDIA(0): Samsung SyncMaster (DFP-1): Internal Dual Link TMDS
[     6.981] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     6.981] (**) NVIDIA(0):     device Samsung SyncMaster (CRT-0) (Using EDID frequencies
[     6.981] (**) NVIDIA(0):     has been enabled on all display devices.)
[     6.981] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     6.981] (**) NVIDIA(0):     device Samsung SyncMaster (DFP-1) (Using EDID frequencies
[     6.981] (**) NVIDIA(0):     has been enabled on all display devices.)
[     6.982] (II) NVIDIA(0): Validated MetaModes:
[     6.982] (II) NVIDIA(0):    
[     6.982] (II) NVIDIA(0):     "CRT:nvidia-auto-select+1680+0,DFP:nvidia-auto-select+0+0"
[     6.982] (II) NVIDIA(0): Virtual screen size determined to be 3360 x 1050
[     7.003] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[     7.003] (--) NVIDIA(0):     option
[     7.003] (--) Depth 24 pixmap format is 32 bpp
[     7.003] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[     7.003] (II) NVIDIA:     access.
[     7.007] (II) NVIDIA(0): Setting mode "CRT:nvidia-auto-select+1680+0,DFP:nvidia-auto-select+0+0"
[     7.110] Loading extension NV-GLX
[     7.165] (==) NVIDIA(0): Disabling shared memory pixmaps
[     7.165] (==) NVIDIA(0): Backing store disabled
[     7.165] (==) NVIDIA(0): Silken mouse enabled
[     7.165] (**) NVIDIA(0): DPMS enabled
[     7.165] Loading extension NV-CONTROL
[     7.166] Loading extension XINERAMA
[     7.166] (II) Loading sub module "dri2"
[     7.166] (II) LoadModule: "dri2"
[     7.166] (II) Module "dri2" already built-in
[     7.166] (II) NVIDIA(0): [DRI2] Setup complete
[     7.166] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[     7.166] (--) RandR disabled
[     7.168] (II) SELinux: Disabled on system
[     7.169] (II) Initializing extension GLX
[     7.182] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[     7.183] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[     7.183] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     7.183] (II) LoadModule: "evdev"
[     7.183] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[     7.184] (II) Module evdev: vendor="X.Org Foundation"
[     7.184]    compiled for 1.14.1, module version = 2.7.3
[     7.184]    Module class: X.Org XInput Driver
[     7.184]    ABI class: X.Org XInput driver, version 19.1
[     7.184] (II) Using input driver 'evdev' for 'Power Button'
[     7.184] (**) Power Button: always reports core events
[     7.184] (**) evdev: Power Button: Device: "/dev/input/event1"
[     7.184] (--) evdev: Power Button: Vendor 0 Product 0x1
[     7.184] (--) evdev: Power Button: Found keys
[     7.184] (II) evdev: Power Button: Configuring as keyboard
[     7.184] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[     7.184] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[     7.184] (**) Option "xkb_rules" "evdev"
[     7.184] (**) Option "xkb_model" "pc105"
[     7.184] (**) Option "xkb_layout" "us"
[     7.185] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[     7.185] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     7.185] (II) Using input driver 'evdev' for 'Power Button'
[     7.185] (**) Power Button: always reports core events
[     7.185] (**) evdev: Power Button: Device: "/dev/input/event0"
[     7.185] (--) evdev: Power Button: Vendor 0 Product 0x1
[     7.185] (--) evdev: Power Button: Found keys
[     7.185] (II) evdev: Power Button: Configuring as keyboard
[     7.185] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[     7.185] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[     7.185] (**) Option "xkb_rules" "evdev"
[     7.185] (**) Option "xkb_model" "pc105"
[     7.185] (**) Option "xkb_layout" "us"
[     7.185] (II) config/udev: Adding drm device (/dev/dri/card0)
[     7.185] (II) config/udev: Ignoring already known drm device (/dev/dri/card0)
[     7.185] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event10)
[     7.185] (II) No input driver specified, ignoring this device.
[     7.185] (II) This device may have been added with another device file.
[     7.185] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event11)
[     7.185] (II) No input driver specified, ignoring this device.
[     7.185] (II) This device may have been added with another device file.
[     7.185] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event12)
[     7.185] (II) No input driver specified, ignoring this device.
[     7.185] (II) This device may have been added with another device file.
[     7.185] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event13)
[     7.185] (II) No input driver specified, ignoring this device.
[     7.185] (II) This device may have been added with another device file.
[     7.185] (II) config/udev: Adding input device Logitech Unifying Device. Wireless PID:4002 (/dev/input/event3)
[     7.185] (**) Logitech Unifying Device. Wireless PID:4002: Applying InputClass "evdev keyboard catchall"
[     7.185] (II) Using input driver 'evdev' for 'Logitech Unifying Device. Wireless PID:4002'
[     7.185] (**) Logitech Unifying Device. Wireless PID:4002: always reports core events
[     7.185] (**) evdev: Logitech Unifying Device. Wireless PID:4002: Device: "/dev/input/event3"
[     7.185] (--) evdev: Logitech Unifying Device. Wireless PID:4002: Vendor 0x46d Product 0xc52b
[     7.185] (--) evdev: Logitech Unifying Device. Wireless PID:4002: Found 1 mouse buttons
[     7.185] (--) evdev: Logitech Unifying Device. Wireless PID:4002: Found scroll wheel(s)
[     7.185] (--) evdev: Logitech Unifying Device. Wireless PID:4002: Found relative axes
[     7.185] (II) evdev: Logitech Unifying Device. Wireless PID:4002: Forcing relative x/y axes to exist.
[     7.185] (--) evdev: Logitech Unifying Device. Wireless PID:4002: Found absolute axes
[     7.185] (II) evdev: Logitech Unifying Device. Wireless PID:4002: Forcing absolute x/y axes to exist.
[     7.186] (--) evdev: Logitech Unifying Device. Wireless PID:4002: Found keys
[     7.186] (II) evdev: Logitech Unifying Device. Wireless PID:4002: Configuring as mouse
[     7.186] (II) evdev: Logitech Unifying Device. Wireless PID:4002: Configuring as keyboard
[     7.186] (II) evdev: Logitech Unifying Device. Wireless PID:4002: Adding scrollwheel support
[     7.186] (**) evdev: Logitech Unifying Device. Wireless PID:4002: YAxisMapping: buttons 4 and 5
[     7.186] (**) evdev: Logitech Unifying Device. Wireless PID:4002: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     7.186] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.2/0003:046D:C52B.0003/input/input3/event3"
[     7.186] (II) XINPUT: Adding extended input device "Logitech Unifying Device. Wireless PID:4002" (type: KEYBOARD, id 8)
[     7.186] (**) Option "xkb_rules" "evdev"
[     7.186] (**) Option "xkb_model" "pc105"
[     7.186] (**) Option "xkb_layout" "us"
[     7.186] (II) evdev: Logitech Unifying Device. Wireless PID:4002: initialized for relative axes.
[     7.186] (WW) evdev: Logitech Unifying Device. Wireless PID:4002: ignoring absolute axes.
[     7.186] (**) Logitech Unifying Device. Wireless PID:4002: (accel) keeping acceleration scheme 1
[     7.186] (**) Logitech Unifying Device. Wireless PID:4002: (accel) acceleration profile 0
[     7.186] (**) Logitech Unifying Device. Wireless PID:4002: (accel) acceleration factor: 2.000
[     7.186] (**) Logitech Unifying Device. Wireless PID:4002: (accel) acceleration threshold: 4
[     7.186] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event4)
[     7.186] (II) No input driver specified, ignoring this device.
[     7.186] (II) This device may have been added with another device file.
[     7.186] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event5)
[     7.186] (II) No input driver specified, ignoring this device.
[     7.186] (II) This device may have been added with another device file.
[     7.186] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event6)
[     7.186] (II) No input driver specified, ignoring this device.
[     7.186] (II) This device may have been added with another device file.
[     7.186] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event7)
[     7.186] (II) No input driver specified, ignoring this device.
[     7.186] (II) This device may have been added with another device file.
[     7.186] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event8)
[     7.186] (II) No input driver specified, ignoring this device.
[     7.186] (II) This device may have been added with another device file.
[     7.186] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event2)
[     7.186] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[     7.186] (II) Using input driver 'evdev' for 'Logitech USB-PS/2 Optical Mouse'
[     7.186] (**) Logitech USB-PS/2 Optical Mouse: always reports core events
[     7.186] (**) evdev: Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event2"
[     7.186] (--) evdev: Logitech USB-PS/2 Optical Mouse: Vendor 0x46d Product 0xc00e
[     7.186] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found 3 mouse buttons
[     7.186] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
[     7.186] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found relative axes
[     7.186] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
[     7.186] (II) evdev: Logitech USB-PS/2 Optical Mouse: Configuring as mouse
[     7.186] (II) evdev: Logitech USB-PS/2 Optical Mouse: Adding scrollwheel support
[     7.187] (**) evdev: Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
[     7.187] (**) evdev: Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     7.187] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input2/event2"
[     7.187] (II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE, id 9)
[     7.187] (II) evdev: Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
[     7.187] (**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
[     7.187] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
[     7.187] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration factor: 2.000
[     7.187] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration threshold: 4
[     7.187] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
[     7.187] (II) No input driver specified, ignoring this device.
[     7.187] (II) This device may have been added with another device file.
[     7.187] (II) config/udev: Adding input device Eee PC WMI hotkeys (/dev/input/event9)
[     7.187] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[     7.187] (II) Using input driver 'evdev' for 'Eee PC WMI hotkeys'
[     7.187] (**) Eee PC WMI hotkeys: always reports core events
[     7.187] (**) evdev: Eee PC WMI hotkeys: Device: "/dev/input/event9"
[     7.187] (--) evdev: Eee PC WMI hotkeys: Vendor 0 Product 0
[     7.187] (--) evdev: Eee PC WMI hotkeys: Found keys
[     7.187] (II) evdev: Eee PC WMI hotkeys: Configuring as keyboard
[     7.187] (**) Option "config_info" "udev:/sys/devices/platform/eeepc-wmi/input/input9/event9"
[     7.187] (II) XINPUT: Adding extended input device "Eee PC WMI hotkeys" (type: KEYBOARD, id 10)
[     7.187] (**) Option "xkb_rules" "evdev"
[     7.187] (**) Option "xkb_model" "pc105"
[     7.187] (**) Option "xkb_layout" "us"
[     7.423] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (CRT-0)) does not support NVIDIA
[     7.423] (II) NVIDIA(GPU-0):     3D Vision stereo.
[     7.423] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     7.423] (**) NVIDIA(0):     device Samsung SyncMaster (CRT-0) (Using EDID frequencies
[     7.423] (**) NVIDIA(0):     has been enabled on all display devices.)
[     7.429] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     7.429] (**) NVIDIA(0):     device Samsung SyncMaster (DFP-1) (Using EDID frequencies
[     7.429] (**) NVIDIA(0):     has been enabled on all display devices.)
[     7.739] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-D-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
[     7.764] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-D-0: nvidia-auto-select @1680x1050 +1680+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
[     7.818] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (CRT-0)) does not support NVIDIA
[     7.818] (II) NVIDIA(GPU-0):     3D Vision stereo.
[     7.818] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     7.818] (**) NVIDIA(0):     device Samsung SyncMaster (CRT-0) (Using EDID frequencies
[     7.818] (**) NVIDIA(0):     has been enabled on all display devices.)
[     7.824] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     7.824] (**) NVIDIA(0):     device Samsung SyncMaster (DFP-1) (Using EDID frequencies
[     7.824] (**) NVIDIA(0):     has been enabled on all display devices.)
[    31.488] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (CRT-0)) does not support NVIDIA
[    31.488] (II) NVIDIA(GPU-0):     3D Vision stereo.
[    31.488] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    31.488] (**) NVIDIA(0):     device Samsung SyncMaster (CRT-0) (Using EDID frequencies
[    31.488] (**) NVIDIA(0):     has been enabled on all display devices.)
[    31.497] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    31.497] (**) NVIDIA(0):     device Samsung SyncMaster (DFP-1) (Using EDID frequencies
[    31.497] (**) NVIDIA(0):     has been enabled on all display devices.)
[    31.507] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +1680+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-D-0: nvidia-auto-select @1680x1050 +1680+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
[    31.555] (II) NVIDIA(0): Setting mode "DVI-I-0: nvidia-auto-select @1680x1050 +1680+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-D-0: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"
share|improve this question
    
Just a guess, but does the same thing happen if you login with gdm –  Amith KK Feb 19 at 2:34
    
could you change all the "DFP-1" to "DFP" and all "CRT-0" to "CRT"? the later are more general. –  timl Feb 19 at 5:40
    
@AmithKK I don't see how the login manager could determine the screen order. That falls into the responsibility of the x-server. –  Cornelius Feb 19 at 17:57
    
@timl I tried it but no change. But like it said, it seems the xorg.conf is read in and orders the screens in the right order but afterwards the nvidia driver kicks in and overrides the xorg settings with its own defaults. –  Cornelius Feb 19 at 17:58
    
do you mean after you changed them, nvidia will override xorg.conf again? the changes was meant to be decide the order like 'all DFP first, then CRT'. because the 'DFP-1, CRT-0' still may become 'DFP-1 first, CRT-0 second, other DFP again, then other CRT'. wild guess for 'why screens get switched' ;) –  timl Feb 20 at 2:16

7 Answers 7

up vote 2 down vote accepted

The issue seems to be, that lightdm resets the screens to an order it sees fit after the xorg.conf has been loaded. (I don't now why or how to suppress that and would find it helpful if some could shed some light on that.)

So to solve this issue the simple solution is to change the display manager. See here

The more complicated solution if you want to keep lightdm is to install arandr. Run it. Set your screens up like you want them and save the configuration. This will save a shell script which sets up your configuration whenever it is executed. So now you have to add the following line to /etc/lightdm/lightdm.conf

session-setup-script=<location of the script you saved with arandr>

This will get you the correct monitor setup as soon as you enter you session.

share|improve this answer

I recently installed 14.04, and found the exact same problem. I tried setting left and right screens in nvidia-settings manager but when I rebooted or restarted X they would switch back.

Searched a lot online, but couldn't find a solution, then I just went to the Displays options in Ubuntu System Settings or unity-control-center, set everything there, and voila, problem solved.

So the easiest thing to do is ignore nvidia-settings and use the displays option in the Ubuntu settings. At least in Ubuntu 14.04.

share|improve this answer

Had the same problem on 13.10 with Nvidia NVS 510 and 4 monitors. Even though nvidia-settings were configured correctly and saved to xorg.conf after reboot rotation options were not remembered.

The solution was to open System SettingsDisplays and configure the monitors again in the proper configuration. Then click Apply. I presume that this is what writes to ~/.config/monitors.xml.

After that everything worked fine and persisted after reboot.

share|improve this answer

You probably need to run:

sudo nvidia-xconfig

See:

share|improve this answer
1  
That just creates a xorg.conf which I already created via the nvidia-settings tool. Also I would created with default settings, meaning the screens would end up in the wrong order. –  Cornelius Feb 19 at 17:52

I had a similar issue - not multi-monitor, but my settings were getting ignored like yours are. What I did to solve it was replace the nvidia-auto-select option with the actual resolution I wanted, i.e. 1280x1024_75 +0+0.

So you might try something like this:

Option         "metamodes" "CRT-0: 1680x1050_75 +1680+0, DFP-1: 1680x1050_75 +0+0"

Additionally, I noticed that in the above line, the monitors are in the order "CRT-0, DFP-1", whereas earlier in your config file they're ordered "DFP-1, CRT-0". I don't know if that matters, but these flip-flops may also be causing your issue, so try setting everything in the same order.

What I think was happening for me was that the nvidia x-server would load its preferred settings, then would be overridden by the settings manager. By removing the auto-select (and any other resolution options available in /etc/X11/xorg.conf) I think it disallows the use of other resolution settings.

share|improve this answer
    
Thanks for the idea, but what matters are the screen resoluiton offsets (i.e. +1680+0) and they but the CRT to the left of the DFP. Also I'm sure now the issue is not in the xorg.conf but something is issuing a call to xrandr after xorg.conf has been loaded (see EDIT2). –  Cornelius Feb 22 at 9:21

I had the same problem in Ubuntu 14.04. It turned out that xorg.conf was overridden by unity-control-center displays settings which are stored in ~/.config/monitors.xml.

Entering the desired settings into monitors.xml solved the issue for me.

  • <primary>no</primary> or <primary>yes</primary>
  • <x>0</x> means left screen, <x>1280</x> right screen where 1280 is width of the screen on the left.
share|improve this answer
    
What are the "desired settings"? –  Whaaaaaat Apr 19 at 20:11

I spent too much time with exactly the same issue: X loads correct settings, then, when I log in, settings are overwritten.

As I am on a fully encrypted single user machine (and therefore don't care about login), my option was to install

nodm

which replaces lightdm or other display managers. It has to be enabled and configured in

/etc/default/nodm

to load at startup and to autologin my user. Perfect solution with the awesome window-manager

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.