Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to make a custom iso, so I used the Ubuntu Customization Kit(UCK). The ISO was created and I used UNetbootin to install it on a 4.0GB SanDisk flash drive. However, when I tried to boot from the flash drive, I got a "no space left on device" error. I ran the "check disk for defects" option and nothing was found. The iso created was ~1GB and the flash drive had 2.6GB of free space after the installation. What can I do to make my ISO bootable?

What I have tried:

  • Re-installing the iso.
  • Trying to boot the flash drive from a different computer
  • Testing with qemu, but all I got was a black screen

    NOTE: The computer was able to boot other flash drives and the the flash drive was able to be booted with a different ISO.

    Thanks in advance.

  • share|improve this question

    Your Answer

     
    discard

    By posting your answer, you agree to the privacy policy and terms of service.

    Browse other questions tagged or ask your own question.