Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to disable "menu" key that emulates right click. It is unfortunately placed on my keyboard and I keep hitting it by mistake instead of AltGr.

This is the key I am talking about.

The key

Is it possible to just permanently disable it? Either make it working as AltGr, or just disable it outright.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Go to system settings --> keyboard --> Shortcuts and locate the menu key in the list. Click on it and hit backspace to disable it.

Note, this answer didn't workfor me that's why I wrote the other one. But this answer works for @KarelBílek, then it will work for others.

share|improve this answer
add comment

the keycode for my menu button is 135. Try for yourself so you disable the correct key.

To test what keycode it is type xev in terminal. Then hit the key and nothing else and look for the keycode in the text in the terminal.

Now execute this command in a new terminal window.

xmodmap -e 'keycode 135 = NoSymbol'

This disables the key and solves your problem. :)

resource

share|improve this answer
1  
Well, that was simple! Thanks! Will accept answer as soon as it's possible. –  Karel Bílek Feb 15 at 21:58
    
What about now? –  Wilf Feb 15 at 21:59
    
Interesting. The first idea worked actually in my case, so you could add it back. Or, as a separate answer. –  Karel Bílek Feb 16 at 0:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.