Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don’t want Update Manager popping up on its own, but I do want to be notified that there are new updates. In older Ubuntu releases (I don’t remember how old), an icon would display in the notification area if there were updates available, with a different look if there were security updates. I could either bring up a terminal and do sudo apt-get upgrade or just click the icon to bring up Update Manager. In 10.10 I ran this command to get that behavior back:

gconftool -s --type bool /apps/update-notifier/auto_launch false

That was working great, but now that I’m running 11.04 with Unity, nothing shows up at all. If I do sudo apt-get upgrade in terminal it installs updates if there are any, but there aren’t always updates and I’d like the nice non-invasive reminder icon back if at all possible. I’ve read about Unity hiding some indicator icons so maybe that’s what’s happening here?

share|improve this question

3 Answers 3

Maybe this helps:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray','update-manager']"
share|improve this answer
    
i tried gsettings get com.canonical.Unity.Panel systray-whitelist and noticed i also had scp-dbus-service in there, so ran this: gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'scp-dbus-service', 'update-manager']". nothing yet but i did just update before posting the question... is there a way to just add a value to that list rather than needing to enter the entire thing? –  misterhaan May 12 '11 at 15:11
1  
according to grep TrayChild ~/.xsession-errors, it’s actually update-notifier, so i changed to that. still waiting for something to show up though. –  misterhaan May 12 '11 at 20:58
    
Ok, wait for updates :) –  Extender May 13 '11 at 4:55

I’ve read about Unity hiding some indicator icons so maybe that’s what’s happening here?

If you do not have dconf-tools installed, install it. Run it (from the terminal or from the launcher: if you do not see it when you type dconf in the launcher, check Main Menu settings), go to desktop>unity>panel. Here you have the list of all classes that Unity allows in the systray.

Add your class there, or change the whole string to ['all'] to allow everything.

share|improve this answer
up vote 2 down vote accepted

I logged in this morning and had my updates icon, just as I wanted! Here’s what worked to get this working using commands in the terminal:

  1. Check what’s already allowed using gsettings get com.canonical.Unity.Panel systray-whitelist since you probably don’t want to turn anything off. My default value was ['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'scp-dbus-service'].
  2. If you suspect you have other missing icons (for example, Pidgin), you can find the correct values to add to the list with grep TrayChild ~/.xsession-errors ― if something tried to add itself to the tray it will show up with the name the system knows it by.
  3. Add update-notifier (and anything else you found in step 2) to the list. If you had the same default values as I did, use this command: gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'scp-dbus-service', 'update-notifier']"
  4. Now set update notifier not to auto-launch (this is from the question): gconftool -s --type bool /apps/update-notifier/auto_launch false

Next time there are updates, you get the icon notifying you ― hooray!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.