Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10.

I am trying to install libgtk2.0-dev, but I am getting the following error message:

The following packages have unmet dependencies.
 libgtk2.0-dev : Depends: libgtk2.0-0 (= 2.24.13-0ubuntu2) but 2.24.17-0ubuntu1~12.10~ricotz0 is to be installed
                 Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed
                 Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
                 Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
                 Recommends: debhelper but it is not going to be installed

I have tried using sudo apt-get -f install as I've seen in other similar questions but it didn't work.

I don't have a lot of experience with Ubuntu/Linux, so could you please explain what I should do?

share|improve this question
    
You have a PPA belonging to ricotz if I'm not wrong (probably for gnome or libreoffice? Maybe for docky ?). That could be the issue here. –  MrVaykadji Feb 15 at 19:35
    
did you try this? –  Avinash Raj Feb 15 at 19:40
    
@AvinashRaj: yes, I did. No results. –  cgf Feb 15 at 19:58
    
@MrVaykadji: yes, I do. Should I remove it? –  cgf Feb 15 at 19:58
    
Did you try to install the package through aptitude? –  Avinash Raj Feb 15 at 19:59
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.