Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

A program started misbehaving, and quickly ate up all 4GB of my RAM and 2GB of my swap. This meant the system came to a crawl. So I forced a shutdown. Now, when I reboot, I would normally get a Grub screen, or an Ubuntu screen, but I only get a flashing cursor, after the POST screen. Preferably without reinstalling, what can I do to fix this? I have a live CD around somewhere which I could boot from. Oh, and I'm using 10.04.

share|improve this question
Hmm, I solved my problem - an SD card was stopping the system from booting! – Thomas O May 13 '11 at 10:52
Please answer your own question and accept. – Sparhawk Aug 10 '14 at 10:50

3 Answers 3

This works for me sometimes and sometimes not.

  1. Boot to live cd.
  2. Open System;Administration;GParted Partition Editor
  3. From the top right of the window, select the drive you need repaired.
  4. Right click on the drive you want to check and select Check.
share|improve this answer

You need to perform a filesystem check, preferable using a LiveUSB (or LiveCD) of Ubuntu.

When you boot your computer, the first stage of GRUB takes control. This first stage is a tiny program that is stored at the start of your hard disk, at the MBR (Master Boot Record). It has the purpose of loading up the second stage of GRUB, which is located in your Ubuntu partition.

So, if GRUB cannot do something meaningful, then most probably the partition is in a mess, cannot be accessed by this cut-down version of GRUB. So you need to use the LiveUSB (or LiveCD) to perform a filesystem check.

  1. Boot from an Ubuntu LiveUSB (or LiveCD)
  2. Start System » Administation » Disk Utility
  3. Perform a filesystem check on your Ubuntu partition.
  4. Shutdown the computer.
  5. Start your again in order to check whether the issue has been resolved!
share|improve this answer
+1 Thanks for your help. I will remember it when there is a real problem. In my case, an SD card was confusing GRUB or the POST stage of the BIOS and it wasn't working. – Thomas O May 23 '11 at 20:56

Answered by OP in comments:

Hmm, I solved my problem - an SD card was stopping the system from booting!

share|improve this answer
No, leave it as a title explaining what they did, linked to the place they explained, then copy and paste exactly what they said. – Tim Aug 10 '14 at 12:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.