Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed ubuntu over a W8 installation (my objective was that only ubuntu remains), the installation completed well and ask to reboot, after that, it only gives me a black screen and

grub rescue>

appeared on the screen. I tried to follow the guide from here: Fixing GRUB error: “error: unknown filesystem” I was capable of finding the .mod files, but a series of issues emerges.

*If found the files in (hd0,gpt5), is the "gpt" a concern??? * after setting

set prefix=(hd0,gpt5)/boot/grub

and trying to load the module

insmod normal

computer says:

error: file '/boot/grub/x86_64-efi/normal.mod' not found

I dont know why it adds the extra 'x86_64-efi' in the directory. Given that the solution doesnt work, I tried loading the module with the complete directory:

insmod (hd0,gpt5)/boot/grub/normal.mod

But this time computer says "invalid arch-dependent ELF magic". I havent been myself capable of advance more than this on my own, please help.


I was capable of run "try ubuntu" from the live usb, I can see all my partitions, the partition with the ubuntu files, the partition with all my data, I would only like to know how to make that ubuntu starts on reboot, nothing else, please help.

share|improve this question
What parition table did you use? msdos or gpt? Did you install the bootloader to sda or to sda1? (assuming your root is on sda). Or did you just install without advanced partitioning? I would suggest you install again, in my experience this is faster than messing around with grub rescue. Open Gparted on the live cd, select msdos as new patition table, create your partitions, start the installer and install grub (on the bottom of the advanced partitioning page) to sdX where X is the letter of the drive you want to install do (it should not have a number following). This will work for sure. – GEO Feb 15 '14 at 14:37
First of all thanks for the response GEO The first installation window ask the type of installation, I choose "Ubuntu only" or so, then It says It will use the entire disc (1 Tera), I was afraid this will erase my data (I have some partitions from my previous windows use, in particular a small one (30 Gb) where windows was installed and a greater one (900 GB or so) where I save every other thing). So I use the assistant and configure the 30 GB partition as root as indicated here link – Francisco Angel Feb 15 '14 at 15:15
Please run the Boot Info Script to which oldfred refers. Without the output from that script, there are two many unknown variables to make any answer more than a guess -- and acting on such guesses could dig you in deeper, so I do not recommend you do anything without more information. – Rod Smith Feb 15 '14 at 18:20


The solution finally came by using boot repair as suggested by other threads. The recommended changes work well for me, now I have another smaller issues, but I going to start another question, because it seems to me that it is an unrelated problem. Thanks everyone for your help.

share|improve this answer
Fixed it for me. Those darned arch elves and their magic – timhc22 Sep 3 '14 at 22:42

Before the install choice by Ubuntu installer is the UEFI menu on booting installer. It should have two choices, UEFI and BIOS, but descriptions are not always clear on which is BIOS or UEFI. If you install on gpt partitioned drive then you have to have an efi partition to boot in UEFI mode or a bios_grub partition to boot in BIOS mode.

Some can manually boot, change example of gpt8 to the partition with your install.

/boot/grub/i386-pc/normal.mod not found Not booting in UEFI mode Manual boot works

set root=(hd0,gpt8)
set prefix=(hd0,gpt8)/boot/grub
insmod linux
linux /vmlinuz root=/dev/sda8 ro
initrd /initrd.img


configfile (hd0,gpt8)/boot/grub/grub.cfg

found that putting grub.cfg into /EFI/ubuntu works, even when grubx64.efi is in /EFI/Boot

IF that does not work post BootInfo. Post the link to the Create BootInfo report. Is part of Boot-Repair:

Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:

You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.