Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

can someone tell me how to fix this,

E: Malformed line 50 in source list /etc/apt/sources.list (dist parse)
E: The list of sources could not be read.

running Ubuntu 12.04, downloading k9copy when happened, appreciate your help and please give step by step instructions I am very new to this. Thanks

share|improve this question

marked as duplicate by Mitch, minerz029, karel, mikewhatever, Ask Feb 15 at 7:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
The answers to the malformed line91 did not work for me, I did not consider duplicate question because of line number but tried after seeing responses anyway. I'll try the deleting and enable multiverse next. –  sageflower Feb 15 at 9:11
    
Could you add your sources.list content. –  Braiam Feb 15 at 15:45
    
Not sure what you are asking? I took Olupot Douglas advice, deleted the source file than update, which solved the problem. Are you wanting to see what was deleted? –  sageflower Feb 15 at 23:36
    
source list to long but can break up in several sections to send if that is what your wanting –  sageflower Feb 15 at 23:40
    
Doesn't matter, you have up to 30000 characters to dump the contents of /etc/apt/sources.list and every file under /etc/apt/sources.list.d/ –  Braiam Feb 16 at 1:54

1 Answer 1

Try making a copy of your sources.list file and then delete the original file (sources.list), and enable multiverse like belowtaken from k9copy

then perform an update

 sudo apt-get update
 sudo apt-get install k9copy

Try that and visit this for details

share|improve this answer
    
I'm going to try this but first would like to know what am I to do with to do with the copy of the source list file? –  sageflower Feb 15 at 9:15
    
keep it just incase you need your original settings. you installed softwares –  Olu Doug Feb 15 at 9:17
    
Thank You! Problem is fixed and using k9copy now –  sageflower Feb 15 at 9:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.