Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I use System Settings-Additional drivers- and try to activate; NVIDIA binary Xorg driver, kernal module and VDPAU library,

I get this message; SystemError:Unable to correct problems,you have held broken packages.

Is there anyway to fix this? Ubuntu 12.04 LTS

share|improve this question
Please open a terminal (CTRL+ALT+T) and issue these commands (one by one) sudo apt-get update & sudo apt-get dist-upgrade & lspci -nnk | grep -iA2 vga . What is the output ? Edit the OP and add the results. – NikTh Feb 15 '14 at 1:03
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G71M [GeForce Go 7900 GS] [10de:0298] (rev a1) Subsystem: Toshiba America Info Systems Device [1179:ff31] Kernel driver in use: nvidia toshiba@toshiba-Satellite-P100:~$ – Bob Feb 16 '14 at 10:48
Sorry pretty new at this, I hope this is what you needed.@NikTh – Bob Feb 16 '14 at 10:57

Use this answer to completely remove nvidia drivers from your system.

Then, reboot the system and when you login to your Desktop Environment, open a terminal (open the terminal with CTRL+ALT+T) and issue the following commands (one by one - copy paste them from here to your terminal).

sudo apt-get update
sudo apt-get install nvidia-173 
sudo nvidia-xconfig 

If above procedure goes well, without errors, then reboot once more and it should be fine.

share|improve this answer
Hello,below is the message after sudo apt-get install nvidia-173. Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package nvida-173 toshiba@toshiba-Satellite-P100:~$ I did not enter in the last command because I'm unsure if I should after this E message?@NiKTh – Bob Feb 16 '14 at 20:20
Did you copy-paste the commands from here to your terminal one by one ? The package nvidia-173 exists. Look here, though the package nvida-173 doesn't . Or maybe you must enable some repository ? Check from software center and enable canonical partners or/and independent example image – NikTh Feb 16 '14 at 21:26
Copied and pasted the commands one by one. Enabled updates on software centre. OP of the 3 commands; toshiba@toshiba-Satellite-P100:~$ sudo apt-get install nvidia-173 Reading package lists... Done Building dependency tree Reading state information... Done nvidia-173 is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. toshiba@toshiba-Satellite-P100:~$ sudo nvidia-xconfig WARNING: Unable to locate/open X configuration file. New X configuration file written to '/etc/X11/xorg.conf' toshiba@toshiba-Satellite-P100:~$ @NikTh – Bob Feb 17 '14 at 0:10
And ? Same problem remains ? Reboot your system and see if the problem has resolved. – NikTh Feb 17 '14 at 0:13
Rebooted system, same problem exists. Except that now nvidia_173, nvidia_304, nvidia_304_updates now show as being active but Nvidia binary Xorg, kernel module and VDPAU library will not activate. Still receive the broken packages message.@NikTh – Bob Feb 17 '14 at 0:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.