Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since Mark Shuttleworth decided to switch to sytemd in the future, I was wondering if I can install it on my Ubuntu now?

share|improve this question
up vote 38 down vote accepted

Wily Werewolf (15.10) and newer:

You don't have to do anything. You are using systemd by default.

Trusty (14.04) and older:

You are out of luck. Ubuntu repositories do not provide the systemd binaries for versions before Utopic, despite the fact that their sources do generate the files. You can learn more about this in this answer.

share|improve this answer
    
Ubuntu 12.04 LTS: Unable to locate package systemd-services . I think you should add at least for which version this works, and/or which repository to add and how. – Anthon Mar 12 '14 at 5:04
    
@Anthon this only works with raring and newer. – Braiam Mar 12 '14 at 5:05
    
Or just raring? On 13.10 systemd-services doesn't include /lib/systemd/systemd, and there isn't another package that does. – sourcejedi Apr 9 '14 at 9:55
    
@sourcejedi you are right, I'm baffled, I've searched all the repository and /lib/systemd/systemd isn't provided by any package before utopic... I'm not sure what's going on since I have /lib/systemd/systemd in my updated-from-raring trusty system. – Braiam Sep 3 '14 at 1:12
1  
@bodhi.zazen That presumes the package comes from the "PPA". If you check around, you will see that to install systemd it uses packages from a PPA. I do not, my instructions use "main" which are packages supported by Ubuntu/Canonical. Of course, people wanting to do the jump should be prepared before even trying. – Braiam Dec 25 '14 at 17:50

add these ppas

sudo add-apt-repository ppa:ondrej/systemd
sudo apt-get update

systemd requires the directory /sys/fs/cgroup as a mountpoint. It doesn't exist in the current Ubuntu kernel (2.6.35). It can't be created with mkdir either because sysfs doesn't allow that. To create the directory this patch from the 2.6.36 kernel must be backported. A suitably patched kernel can be pulled via apt-get

sudo apt-get install linux-image-2.6.35-23-generic=2.6.35-23.41ppa1 linux-headers-2.6.35-23-generic=2.6.35-23.41ppa1 linux-headers-2.6.35-23=2.6.35-23.41ppa1

then install systemd

 sudo apt-get install systemd libpam-systemd systemd-gui systemd-extra-units

for more information go to this link

share|improve this answer
    
Which version of currently supported Ubuntu runs kernel 2.6.35? – user68186 Feb 14 '14 at 18:00
    
The PPA, nor the installing of 'dependencies' works :/ – blade19899 Feb 14 '14 at 18:20
2  
I wouldn't install kernel 2.6 nor older in any of my systems – Braiam Feb 14 '14 at 18:35
1  
That wiki information is really out of date, I read it as well when trying to find the answer to this question and was not impressed – michel-slm Mar 13 '14 at 1:47
1  
He seems to have removed his PPA. – zerwas Nov 30 '14 at 1:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.