Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night, I updated from Ubuntu 12.04 to 12.10. This morning, I logged in to my computer, only to get a black screen. I am able to access the shell by pressing the escape key while the Ubuntu logo shows, but I cannot use any desktop environments (gnome, Unity, et al.)

I received an error about there being no screens in xorg- I uninstalled xorg (a stupid idea?) and attempted to reinstall it, only to find that the current xorg package is broken.

One thing that may be helpful- when I hit CTRL+ALT+F7, my startup programs run, suggesting that the only thing really wrong is my desktop. I run BOINC (which heats my computer up significantly), and I can physically tell it is running.

I have backups of all my files, but I have spent a lot of time and energy getting everything the way I want.

Thanks to anyone who can help- I have spent (wasted) about 4 hours trying to fix this. It could be there is a simple solution to this, but I can't find it. Pardon my ignorance.

EDIT:

I am running a 64-bit Lenovo Thinkpad x230. According to

lspci -nn | grep VGA

I have a Intel Corporation 3rd Gen Core processor Graphics Controller. I am able to get tty sessions 1-7, but just can't make Unity (or any other graphical interface) work.

I gave up trying to fix this and reinstalled, which actually worked out OK (though I lost pretty much the whole day in terms of working time). I still have the install, though and would like to see everything work.

share|improve this question
    
Can you get into a tty? Ctrl+Alt+F1? What graphics card do you have? Do you have any drivers installed for it? –  Seth Feb 14 at 22:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.