Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu 12.04 LTS server hosted in a XEN VPS. Strictly being used in terminal mode via PuTTY.

uname -a
Linux webserver 3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:37:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

It works like a charm since 8 months and I have regularly updated it without big hassles so far.

I logged on yesterday and found out it prompted for a number of updates. One of them mentioned "change in how services start up blah blah".

I applied them and rebooted. I always reboot to be sure every patch leads to a bootable system.

They system booted too fast and running htop revealed a memory usage of just 75M (!) instead of the usual 800M.

I started my routine checks and quickly found out varnish was missing its shared library. It just got removed and yes I tried the (sudo) ldconfig stuff.

I easily fixed this by reinstalling:

sudo apt-get install libvarnish-dev

omitting the sudo portion for those who are logged on as root of course.

But the second bit, I don't know how to fix it. Not a single daemon or service has started. No error message, nothing. Stuff can still be manually started by command line but of course it's a ton of services each with its own configuration etc. My mind goes immediately to the release note telling the services startup has been changed. Sure it looked mostly cosmetic to me (Adding a [......] visual feedback with success or failure notification) but I see it is not just cosmetic.

For now I have resolved by restoring the backup I have made prior to patching but that's not a viable long term solution.

What can I do to upgrade my system AND also make my services all boot with the new boot procedures? I mean, is there a "painless and transparent" upgrade path?

After reverting to the backup, I can show the list of packages I am prompted to update. If I update them, my box completely breaks in the services startup and have to restore again (I tried already twice).

root@webserver:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done

The following packages have been kept back:
  dmsetup libdevmapper1.02.1 lsb-release udev
The following packages will be upgraded:
  init-system-helpers initscripts insserv kmod libaprutil1 libkmod2
  libselinux1 lsb-base module-init-tools sysv-rc sysvinit-utils
11 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

Notice how until this upgrade I did not even have "kept back" packages.

share|improve this question
    
I just received a reply (from Ondrej none the less!) to a previous "startup issues" question of mine. Anyone could maybe make a connection? askubuntu.com/questions/327331/… –  Dario Fumagalli Feb 14 at 9:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.