Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

During installation I selected the alternative international keyboard. The problem with this keyboard that a double-quote character doesn't get typed until a space is pressed. Same for tilde (~) and single quote (').

I cannot get this keyboard removed. I tried to click on my keyboard applet, selecting keyboard preferences, removing the alternative keyboard. But every time I restart, the alternative keyboard is back again.

How can this be removed?

share|improve this question
    
Have you tried adding another one (US non-international) and then removing the international one? Unfortunately keyboards layouts have long been plagued by bugs. –  loevborg May 11 '11 at 19:27
    
@loevborg: Yes, I tried. It's really frustrating that it keeps getting back to the alternative keyboard, if if you try to remove it. –  Roalt May 13 '11 at 14:06
    
I would encourage you to file a bug on launchpad. –  loevborg May 14 '11 at 13:10
    
@loevborg: Thanks, I wasn't sure it was a bug: I filled a bug for it now: bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/782941 –  Roalt May 15 '11 at 9:30
    
I didn't yet get any reaction on my filed bug. I hope that others on askubuntu have some fixes for me. –  Roalt May 24 '11 at 18:36
show 1 more comment

3 Answers 3

up vote 2 down vote accepted
+50

install the other keyboard setting and select the proper keyboard setting when logging in.

share|improve this answer
    
Thanks! The answer looks quite trivial, but if you do not know it, it's really frustrating that changing the keyboard settings doesn't give you a warning that you cannot remove the selected keyboard setting. –  Roalt May 27 '11 at 17:12
add comment

You cannot remove a keyboard layout if it's set as default for the session. Log out, change the layout for the session from the menu at the bottom panel, log in again, then you can remove it in the keyboard preferences.

share|improve this answer
    
Thank you for the answer! I'll accept @dago's answer because he was a bit earlier than you, although your's is more verbose. –  Roalt May 27 '11 at 17:14
add comment

You can type

sudo dpkg-reconfigure console-setup

in order to reconfigure the console and X default keyboard settings.

The default layout is stored in /etc/default/console-setup and the above script edits the configuration file.

share|improve this answer
    
It doesn't help: my bug is relatied to the X environment, not the console environment. –  Roalt May 15 '11 at 9:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.