Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today, I upgraded my desktop from 13.04 to 13.10 and ended up with the following:

$ sudo apt-get upgrade
Reading package lists...
Building dependency tree...
Reading state information...
The following packages have been kept back:
  libxfce4ui-1-0 libxfce4ui-utils parole xfce-keyboard-shortcuts
  xfce4-settings xfce4-xkb-plugin xfdesktop4 xfdesktop4-data xfwm4
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
77 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up python3 (3.3.2-14ubuntu1) ...
running python rtupdate hooks for python3.3...
dpkg-query: package 'ubiquity-frontend-gtk' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 200, in <module>
    main()
  File "/usr/bin/py3clean", line 186, in main
    pfiles = set(dpf.from_package(options.package))
  File "/usr/share/python3/debpython/files.py", line 53, in from_package
    raise Exception("cannot get content of %s" % package_name)
Exception: cannot get content of ubiquity-frontend-gtk
error running python rtupdate hook ubiquity-frontend-gtk
dpkg-query: package 'ubiquity' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 200, in <module>
    main()
  File "/usr/bin/py3clean", line 186, in main
    pfiles = set(dpf.from_package(options.package))
  File "/usr/share/python3/debpython/files.py", line 53, in from_package
    raise Exception("cannot get content of %s" % package_name)
Exception: cannot get content of ubiquity
error running python rtupdate hook ubiquity
dpkg: error processing python3 (--configure):
 subprocess installed post-installation script returned error exit status 4
dpkg: dependency problems prevent configuration of python3-apt:
 python3-apt depends on python3 (>= 3.3); however:
  Package python3 is not configured yet.
 python3-apt depends on python3 (<< 3.4); however:
  Package python3 is not configured yet.

dpkg: error processing python3-apt (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of python3-dbus:
 python3-dbus depends on python3 (>= 3.3); however:
  Package python3 is not configured yet.
 python3-dbus depends on python3 (<< 3.4); however:
  Package python3 is not configured yet.

dpkg: error processing python3-dbus (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of language-selector-common:
 language-selector-common depends on python3 (>= 3.2); however:
  Package python3 is not configured yet.
 language-selector-common depends on python3:any (>= 3.2.3-3~); however:
  Package python3 is not configured yet.
 language-selector-common depends on python3-apt (>= 0.7.12.0); however:
  Package python3-apt is not configured yet.
 language-selector-common depends on python3-dbus; however:
  Package python3-dbus is not configured yet.

dpkg: error processing language-selector-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-gi:
 python3-gi depends on python3 (<< 3.4); however:
  Package python3 is not configured yet.
 python3-gi depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-gi depends on python3 (>= 3.3); however:
  Package python3 is not configured yet.

dpkg: error processing python3-gi (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-drivers-common:
 ubuntu-drivers-common depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.
 ubuntu-drivers-common depends on python3-apt; however:
  Package python3-apt is not configured yet.

dpkg: error processing ubuntu-drivers-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of update-notifier-common:
 update-notifier-common depends on python3:any; however:
  Package python3 is not configured yet.
 update-notifier-common depends on python3-apt; however:
  Package python3-apt is not configured yet.

dpkg: error processing update-notifier-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of lsb-release:
 lsb-release depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.

dpkg: error processing lsb-release (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on lsb-release; however:
  Package lsb-release is not configured yet.
 ubuntu-minimal depends on python3; however:
  Package python3 is not configured yet.

dpkg: error processing ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of apparmor:
 apparmor depends on python3; however:
  Package python3 is not configured yet.

dpkg: error processing apparmor (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-commandnotfound:
 python3-commandnotfound depends on lsb-release; however:
  Package lsb-release is not configured yet.
 python3-commandnotfound depends on python3-apt; however:
  Package python3-apt is not configured yet.
 python3-commandnotfound depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.

dpkg: error processing python3-commandnotfound (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of command-not-found:
 command-not-found depends on python3-commandnotfound (>= 0.3ubuntu7); however:
  Package python3-commandnotfound is not configured yet.

dpkg: error processing command-not-found (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-distupgrade:
 python3-distupgrade depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-distupgrade depends on python3-apt (>= 0.8.5~); however:
  Package python3-apt is not configured yet.
 python3-distupgrade depends on lsb-release; however:
  Package lsb-release is not configured yet.

dpkg: error processing python3-distupgrade (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-update-manager:
 python3-update-manager depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-update-manager depends on python3-apt (>= 0.8.5~); however:
  Package python3-apt is not configured yet.
 python3-update-manager depends on python3-distupgrade; however:
  Package python3-distupgrade is not configured yet.
 python3-update-manager depends on lsb-release; however:
  Package lsb-release is not configured yet.

dpkg: error processing python3-update-manager (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-core:
 ubuntu-release-upgrader-core depends on python3:any (>= 3.2); however:
  Package python3 is not configured yet.
 ubuntu-release-upgrader-core depends on python3; however:
  Package python3 is not configured yet.
 ubuntu-release-upgrader-core depends on python3-distupgrade (= 1:0.205.4); however:
  Package python3-distupgrade is not configured yet.

dpkg: error processing ubuntu-release-upgrader-core (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-standard:
 ubuntu-standard depends on language-selector-common; however:
  Package language-selector-common is not configured yet.

dpkg: error processing ubuntu-standard (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ufw:
 ufw depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.

dpkg: error processing ufw (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of update-manager-core:
 update-manager-core depends on python3:any (>= 3.2); however:
  Package python3 is not configured yet.
 update-manager-core depends on python3; however:
  Package python3 is not configured yet.
 update-manager-core depends on python3-update-manager (= 1:0.194.1); however:
  Package python3-update-manager is not configured yet.
 update-manager-core depends on lsb-release; however:
  Package lsb-release is not configured yet.
 update-manager-core depends on ubuntu-release-upgrader-core; however:
  Package ubuntu-release-upgrader-core is not configured yet.

dpkg: error processing update-manager-core (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gnome-menus:
 gnome-menus depends on python3; however:
  Package python3 is not configured yet.
 gnome-menus depends on python3:any (>= 3.1); however:
  Package python3 is not configured yet.

dpkg: error processing gnome-menus (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of alacarte:
 alacarte depends on gnome-menus (>= 3.5.3); however:
  Package gnome-menus is not configured yet.

dpkg: error processing alacarte (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-problem-report:
 python3-problem-report depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.

dpkg: error processing python3-problem-report (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-apport:
 python3-apport depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-apport depends on python3-apt (>= 0.7.9); however:
  Package python3-apt is not configured yet.
 python3-apport depends on python3-problem-report (>= 0.94); however:
  Package python3-problem-report is not configured yet.
 python3-apport depends on lsb-release; however:
  Package lsb-release is not configured yet.

dpkg: error processing python3-apport (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of apport:
 apport depends on python3; however:
  Package python3 is not configured yet.
 apport depends on python3-apport (>= 2.12.5-0ubuntu2.2); however:
  Package python3-apport is not configured yet.
 apport depends on python3-gi; however:
  Package python3-gi is not configured yet.

dpkg: error processing apport (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on python3; however:
  Package python3 is not configured yet.
 apport-gtk depends on python3-apport (>= 2.12.5-0ubuntu2.2); however:
  Package python3-apport is not configured yet.
 apport-gtk depends on python3-gi; however:
  Package python3-gi is not configured yet.
 apport-gtk depends on apport (>= 0.41); however:
  Package apport is not configured yet.

dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of apparmor-easyprof:
 apparmor-easyprof depends on python3; however:
  Package python3 is not configured yet.
 apparmor-easyprof depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.

dpkg: error processing apparmor-easyprof (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of dh-apparmor:
 dh-apparmor depends on apparmor-easyprof; however:
  Package apparmor-easyprof is not configured yet.

dpkg: error processing dh-apparmor (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of debhelper:
 debhelper depends on dh-apparmor; however:
  Package dh-apparmor is not configured yet.

dpkg: error processing debhelper (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of devhelp-common:
 devhelp-common depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.

dpkg: error processing devhelp-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libdevhelp-3-2:
 libdevhelp-3-2 depends on devhelp-common (>= 3.8.2-2); however:
  Package devhelp-common is not configured yet.

dpkg: error processing libdevhelp-3-2 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of devhelp:
 devhelp depends on libdevhelp-3-2 (>= 3.6.1); however:
  Package libdevhelp-3-2 is not configured yet.

dpkg: error processing devhelp (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of firefox:
 firefox depends on lsb-release; however:
  Package lsb-release is not configured yet.

dpkg: error processing firefox (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of flashplugin-installer:
 flashplugin-installer depends on update-notifier-common (>= 0.119ubuntu2); however:
  Package update-notifier-common is not configured yet.

dpkg: error processing flashplugin-installer (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of foomatic-db-compressed-ppds:
 foomatic-db-compressed-ppds depends on python3; however:
  Package python3 is not configured yet.

dpkg: error processing foomatic-db-compressed-ppds (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gnome-control-center:
 gnome-control-center depends on gnome-menus (>= 2.12.0); however:
  Package gnome-menus is not configured yet.

dpkg: error processing gnome-control-center (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of kde-runtime:
 kde-runtime depends on language-selector-common; however:
  Package language-selector-common is not configured yet.

dpkg: error processing kde-runtime (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of qapt-batch:
 qapt-batch depends on kde-runtime; however:
  Package kde-runtime is not configured yet.

dpkg: error processing qapt-batch (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of kubuntu-debug-installer:
 kubuntu-debug-installer depends on kde-runtime; however:
  Package kde-runtime is not configured yet.
 kubuntu-debug-installer depends on qapt-batch; however:
  Package qapt-batch is not configured yet.

dpkg: error processing kubuntu-debug-installer (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of software-center-aptdaemon-plugins:
 software-center-aptdaemon-plugins depends on python3-gi; however:
  Package python3-gi is not configured yet.

dpkg: error processing software-center-aptdaemon-plugins (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-pkg-resources:
 python3-pkg-resources depends on python3 (>= 3.2); however:
  Package python3 is not configured yet.
 python3-pkg-resources depends on python3 (<< 3.4); however:
  Package python3 is not configured yet.

dpkg: error processing python3-pkg-resources (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-aptdaemon:
 python3-aptdaemon depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-aptdaemon depends on python3-apt (>= 0.8.5~ubuntu1); however:
  Package python3-apt is not configured yet.
 python3-aptdaemon depends on python3-dbus; however:
  Package python3-dbus is not configured yet.
 python3-aptdaemon depends on python3-gi; however:
  Package python3-gi is not configured yet.
 python3-aptdaemon depends on python3-pkg-resources; however:
  Package python3-pkg-resources is not configured yet.

dpkg: error processing python3-aptdaemon (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of aptdaemon:
 aptdaemon depends on python3:any (>= 3.2); however:
  Package python3 is not configured yet.
 aptdaemon depends on python3-aptdaemon (= 1.1.1-0ubuntu4); however:
  Package python3-aptdaemon is not configured yet.
 aptdaemon depends on python3-gi; however:
  Package python3-gi is not configured yet.

dpkg: error processing aptdaemon (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-aptdaemon.gtk3widgets:
 python3-aptdaemon.gtk3widgets depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-aptdaemon.gtk3widgets depends on python3-aptdaemon (= 1.1.1-0ubuntu4); however:
  Package python3-aptdaemon is not configured yet.
 python3-aptdaemon.gtk3widgets depends on python3-gi; however:
  Package python3-gi is not configured yet.

dpkg: error processing python3-aptdaemon.gtk3widgets (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of language-selector-gnome:
 language-selector-gnome depends on language-selector-common (= 0.116); however:
  Package language-selector-common is not configured yet.
 language-selector-gnome depends on python3 (>= 3.2); however:
  Package python3 is not configured yet.
 language-selector-gnome depends on python3:any (>= 3.2.3-3~); however:
  Package python3 is not configured yet.
 language-selector-gnome depends on python3-gi; however:
  Package python3-gi is not configured yet.
 language-selector-gnome depends on python3-apt; however:
  Package python3-apt is not configured yet.
 language-selector-gnome depends on aptdaemon (>= 0.40+bzr527); however:
  Package aptdaemon is not configured yet.
 language-selector-gnome depends on python3-aptdaemon.gtk3widgets; however:
  Package python3-aptdaemon.gtk3widgets is not configured yet.

dpkg: error processing language-selector-gnome (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of nvidia-common:
 nvidia-common depends on ubuntu-drivers-common; however:
  Package ubuntu-drivers-common is not configured yet.

dpkg: error processing nvidia-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of screen-resolution-extra:
 screen-resolution-extra depends on python3-gi; however:
  Package python3-gi is not configured yet.

dpkg: error processing screen-resolution-extra (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of nvidia-settings-304:
 nvidia-settings-304 depends on screen-resolution-extra (>= 0.12); however:
  Package screen-resolution-extra is not configured yet.

dpkg: error processing nvidia-settings-304 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-cairo:
 python3-cairo depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.

dpkg: error processing python3-cairo (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-gi-cairo:
 python3-gi-cairo depends on python3 (<< 3.4); however:
  Package python3 is not configured yet.
 python3-gi-cairo depends on python3 (>= 3.3); however:
  Package python3 is not configured yet.
 python3-gi-cairo depends on python3-gi (= 3.10.0-1ubuntu1); however:
  Package python3-gi is not configured yet.
 python3-gi-cairo depends on python3-cairo (>= 1.10.0+dfsg-3~exp2); however:
  Package python3-cairo is not configured yet.

dpkg: error processing python3-gi-cairo (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of onboard:
 onboard depends on python3 (>= 3.3); however:
  Package python3 is not configured yet.
 onboard depends on python3 (<< 3.4); however:
  Package python3 is not configured yet.
 onboard depends on python3-cairo; however:
  Package python3-cairo is not configured yet.
 onboard depends on python3-gi-cairo; however:
  Package python3-gi-cairo is not configured yet.
 onboard depends on python3-dbus; however:
  Package python3-dbus is not configured yet.

dpkg: error processing onboard (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of onboard-data:
 onboard-data depends on onboard (>= 0.99.0~alpha1~tr1507); however:
  Package onboard is not configured yet.

dpkg: error processing onboard-data (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of openprinting-ppds:
 openprinting-ppds depends on python3; however:
  Package python3 is not configured yet.

dpkg: error processing openprinting-ppds (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 python3
 python3-apt
 python3-dbus
 language-selector-common
 python3-gi
 ubuntu-drivers-common
 update-notifier-common
 lsb-release
 ubuntu-minimal
 apparmor
 python3-commandnotfound
 command-not-found
 python3-distupgrade
 python3-update-manager
 ubuntu-release-upgrader-core
 ubuntu-standard
 ufw
 update-manager-core
 gnome-menus
 alacarte
 python3-problem-report
 python3-apport
 apport
 apport-gtk
 apparmor-easyprof
 dh-apparmor
 debhelper
 devhelp-common
 libdevhelp-3-2
 devhelp
 firefox
 flashplugin-installer
 foomatic-db-compressed-ppds
 gnome-control-center
 kde-runtime
 qapt-batch
 kubuntu-debug-installer
 software-center-aptdaemon-plugins
 python3-pkg-resources
 python3-aptdaemon
 aptdaemon
 python3-aptdaemon.gtk3widgets
 language-selector-gnome
 nvidia-common
 screen-resolution-extra
 nvidia-settings-304
 python3-cairo
 python3-gi-cairo
 onboard
 onboard-data
 openprinting-ppds
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any idea how to fix these?

share|improve this question

3 Answers 3

Your system is in a rather fragile state and if you do anything wrong you may need to reinstall the system. So first of all do a backup of all important information. Now, lets first understand your problem:

  1. There are too many not completely installed packages:

    77 not fully installed or removed.

    This is rather preocupating.

  2. error running python rtupdate hook ubiquity-frontend-gtk

    This means that is something really bad. But still that doesn't explain why you have ubiquity related package. So I would recommend you to remove it.

  3. Dependency hell!

    There are lots of:

    Package python3 is not configured yet

    Python is one of the most important packages in any ubuntu installation. Most of the system is built over python and if that package has problems is very, very likely you are in a irrecoverable state.

Solution.

There are ways to do carpet bombing trying to fix your installation but if I aren't there in front of the system, I would recommend anyone to do it. The easier way to fix it is reinstalling the system after doing backups, verify that the disk is in a good state and install Ubuntu over.

share|improve this answer
    
Well, interestingly enough, I am not experiencing any python-related problems whatsoever. The binaries are there and as far as I've tested, python scripts works just fine. That means that trying to flag the python3 package as fully configured might just be the way out of the dependency hell. –  Witiko Feb 14 at 12:49
    
@Witiko yeah, that would be the solution (along with removing Ubiquity package) but hey, there're tons of other packages along the way. –  Braiam Feb 14 at 14:36
    
Still sounds like much less hassle than reinstalling the entire system, though. I'll see what I can do. –  Witiko Feb 14 at 16:05
    
@Witiko I still think that is less than trying to fix the system. –  Braiam Feb 15 at 2:07
    
Thankfully not, see my self-answer below. –  Witiko Feb 15 at 2:10
up vote 1 down vote accepted

In the end, all that was needed to be done was to install the ubiquity-frontend-gtk package. Once that was done, python3 would no longer die during its configuration and with it, the remaining 76 packages could be installed. Afterwards, I removed the ubiquity package.

share|improve this answer

For those with the same problem:

Installing ubiquity-frontend-gtk package solved my dependency errors installing my Epson workforce WF-3520 printer drivers.

share|improve this answer
    
This pretty much confirms the accepted answer. –  Witiko Mar 1 at 12:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.