Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot sync my documents to Ubuntu One. I get this message File Sync error. (auth failed (AUTH_FAILED)) when I click on Ubuntu One from Preferences.

I have tried clearing the Ubuntu One entries in Password and Encryption Keys but that doesn't seem to be the problem. I am using Ubuntu 11.04 and am fairly new to Linux.

share|improve this question
    
user20248: Having the same results as you. I have noticed that the Ubuntu One client does seem to pull down information on connected devices so there is network activity at some level. I have the following messages in my syncdaemon.log file: 2011-07-10 14:18:34,956 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SYS_STATE_CHANGED, kwargs: {'state': AUTHENTICATE (error=False connected=True online=False) Queue: WORKING Connection: With User With Network} 2011-07-10 14:18:35,311 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SYS_AUTH_ERROR, kwargs: {'error': 'AUTHENTICATION_FAILED'} 2011-07-10 1 –  user21382 Jul 10 '11 at 2:42

1 Answer 1

ROOT_MISMATCH in syncdaemon.log - This normally indicates that there may be two Ubuntu One accounts, one in the local cache and another setup in the keyring. This happens if the user installed Ubuntu One with one account and then sets up the computer again with a different account (but all the old Ubuntu One files in ~/.local/share/ubuntuone are still there under the old account). Working around this:

Open Applications->Accessories->Terminal and run:

u1sdtool -q; killall ubuntuone-login ubuntuone-preferences;
sudo rm -rf ~/.local/share/ubuntuone
rm -rf ~/.cache/ubuntuone
rm -rf ~/.config/ubuntuone
mv ~/Ubuntu\ One/ ~/Ubuntu\ One_old/ 

Open Applications->Accessories->Passwords and Encryption Keys, go to the Passwords tab, delete the Ubuntu One and Desktopcouch tokens by right-clicking on them and selecting "Delete".

Back in a terminal session, run:

u1sdtool -q; killall ubuntuone-login; u1sdtool -c 

To get things functioning again, all I had to do was delete my ~/.local/share/ubuntuone directory as indicated above. The u1sdtool line noted above did nothing for me. I mention this just so you do not stop prematurely. Hope this helps.

share|improve this answer
1  
Basically worked for me though all I had to do was use u1sdtool --quit Then go in a delete all the Ubuntu One and desktop couch stuff from the passwords and keys (there were several). After this I started the Ubuntu One gui, hit the "already have account" button, entered in my login and everything re-synced fine. –  Dennis Feb 18 '12 at 21:33

protected by Community Sep 1 '11 at 21:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.