Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo y510p laptop that came pre installed with windows 8. After some shenanigans I ended up having to completely wipe everything off of it. So now I have a blank hard drive and a usb disk with a legal Win 7 on it and another one with Ubuntu 12.04. I have tried every topic on these forums and still cannot get dual boot to work. I can install win7 and it will work just fine. I than install ubuntu 12.04 and I lose win7, but ubuntu than works fine. When I install ubuntu I do not get the option to install side by side with Win7 and when I run os-prober I get this:

/dev/sdb1:Windows 7 (loader):Windows:chain

After running boot repair and selecting the Win7 loader in grub, I get this message:

error: invalid EFI file path

When I try to boot from legacy mode I get a message stating that BOOTMGR is missing.

Based on the suggestion in the comments I tried to format my win7 install into an EFI format and install everything in EFI only mode. The windows installer loads than freezes at the splash screen. Also my ubuntu live usb will not boot, grub comes up than no matter what option I select it will go to a black screen and freeze up. It seems that UEFI mode is just plain broken on the y510p unless your running win8. I tried secure boot on and off, also tried the "other operating system" and "windows 8" modes all with the same results. In legacy mode my unmodified win7 live usb and my ubuntu 12.04.4 live usb's will boot up and install.

So I went back to legacy mode, successfully installed win7 and than put in the ubuntu live usb. From there I ran fixparts and now gparted can see my windows partition. os-prober has the same output, and the ubuntu installer still cannot see any other os's on my machine.

I ran boot repair and was given this URL: http://paste.ubuntu.com/6952157/

My computer only has one hybrid drive, /dev/sda is the SSD and /dev/sdb is the HDD, I don't know if this has anything to do with my issues.

share|improve this question
    
Windows 7 DVD will install in BIOS mode and incorrectly convert drive from gpt to MBR. It leaves backup gpt partition table which you can use fixparts to remove. Then install Ubuntu in BIOS boot mode. Or convert Windows DVD to flash drive and make some minor changes to make it UEFI and install it in UEFI mode. rodsbooks.com/fixparts To convert: forums.lenovo.com/t5/tkb/articleprintpage/tkb-id/Beta_OS@tkb/… –  oldfred Feb 13 at 23:59
    
Post link to BootInfo report in first post. help.ubuntu.com/community/Boot-Info –  oldfred Feb 17 at 16:37
    
You have to disable the Smart Response Technology that combines /dev/sda and /dev/sdb into a single hybrid drive. This thing is Windows only and does not work in Linux. See askubuntu.com/questions/190689/… –  user68186 Feb 19 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.