Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am try to resolve some libboost problems. Eventually i decided it would be easier to remove it cleanly and start from scratch. But when i run sudo apt-get --purge remove libboost* i get:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libcmis-0.3-3 : Depends: libboost-date-time1.53.0 but it is not going to be installed
 liborcus-0.6-0 : Depends: libboost-system1.53.0 but it is not going to be installed
 libreoffice-core : Depends: libboost-date-time1.53.0 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

so i run sudo apt-get -f install and get

Reading database ... 200480 files and directories currently installed.)
Unpacking libboost1.54-dev (from .../libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/quickbook', which is also in package libboost1.53-tools-dev 1.53.0-6+exp3ubuntu8
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.54-dev_1.54.0-2ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

so now im stuck in this loop and can't neither uninstall nor install

What shoud i do?

share|improve this question
up vote 1 down vote accepted

Run sudo dpkg -r libboost1.53-tools-dev, then you should be able to do the apt-get -f install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.