Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installation of AMD proprietary FGLRX graphics driver fails on 11.04 which was upgraded from 10.10

sudo apt-get install fglrx fglrx-amdcccle
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libknewstuff2-4 libqt4-test kdesudo libqt4-help python-qt4 python-sip libvncserver0 libqtassistantclient4 update-manager-kde libqt4-scripttools python-kde4
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  fglrx fglrx-amdcccle
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/40,3 MB of archives.
After this operation, 124 MB of additional disk space will be used.
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg: warning: parsing file '/var/lib/dpkg/available' near line 59749 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
(Reading database ... 511988 files and directories currently installed.)
Unpacking fglrx (from .../fglrx_2%3a8.840-0ubuntu4_amd64.deb) ...
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56859 package 'virtualbox-2.2':
 error in Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number
dpkg-divert: warning: parsing file '/var/lib/dpkg/status' near line 56860 package 'virtualbox-2.2':
 error in Config-Version string '2.2.4-47978_Ubuntu_jaunty': invalid character in revision number

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the ATI driver
 is not installed, the ATI driver is only partially installed,
 or the current ATI driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the FORCE_ATI_UNINSTALL
 environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: error processing /var/cache/apt/archives/fglrx_2%3a8.840-0ubuntu4_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Selecting previously deselected package fglrx-amdcccle.
Unpacking fglrx-amdcccle (from .../fglrx-amdcccle_2%3a8.840-0ubuntu4_amd64.deb) ...
Errors were encountered while processing:
 /var/cache/apt/archives/fglrx_2%3a8.840-0ubuntu4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question

closed as off-topic by bain, guntbert, Tim, Mikołaj Bartnicki, Kevin Bowen Aug 7 at 20:58

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – bain, guntbert, Kevin Bowen
  • "This question is specific to an end of life Ubuntu release. These are no longer supported and are therefore off-topic here. To upgrade, see: How to install software or upgrade from old unsupported release?" – Tim, Mikołaj Bartnicki
If this question can be reworded to fit the rules in the help center, please edit the question.

    
go on - give us a hint - what failed, error messages - anything about your computer, what have you tried, what were you doing. –  fossfreedom May 11 '11 at 17:34

2 Answers 2

Try removing the fglrx driver and then reinstall it.

sudo apt-get purge fglrx

Then you can either install fglrx again from the Ubuntu repos or use the fglrx installer script that the Kanotix distro's leader wrote.

If you choose to install from the Ubuntu repos, just run

sudo apt-get install fglrx fglrx-amdcccle

If you choose to use the Kanotix script, which I highly recommend (it downloads the latest fglrx driver and contains patches to support newer kernel versions):

cd /tmp
wget http://kanotix.net/files/install-fglrx-debian.sh
chmod +x install-fglrx-debian.sh

Then press Control + Alt + F2. You will be put in a TTY. Login with your username and password, then run

cd /tmp
sudo ./install-fglrx-debian.sh
share|improve this answer
    
when i used the script, everything just got messed, i don't know why it gave me lots of error during the installation of the driver. –  Uri Herrera May 14 '11 at 8:05

It looks like your dpkg status is highly corrupted. (many lines of dpkg-divert warnings)

Try:

sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad

sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

in Terminal. Reboot, and try the installation again. If it fails, do the entire procedure at: https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

I've had this issue before, and it really helps.

share|improve this answer
    
Oh, and try(as per @ChenXiaoLong 's answer) sudo apt-get purge flgrx after trying my commands I gave. –  hexafraction Jun 6 '12 at 11:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.