Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My PC specifications:

  • Dell Latitude D830.
  • Fresh install of Ubuntu 12.04 (64bit) dual boot with windows xp pro 6 days ago.

  • Chip ID is Broadcom BCM4311.

  • PCI-ID is [14e4:4312]

  • Last week I installed Unbutu 12.04 (32bit) on two other old Dell
    laptops, an Inspiron 6000 and an Inspiron 9000, with absolutely no
    problems. One dual boot and the other on its own.

  • I am totally new to this, never installed an os before and having
    never even seen Ubuntu before last week...so simple answers please :)

This third install went very smoothly, though I had to do it hardwired to the internet, since it couldn't find the wireless: wireless works perfectly in Windows. When restarting after the OS install, the screen got stuck on the Ubuntu logo splash page with the 5 dots. I pressed the button and then rebooted. I have tried all that I could find in this forum on fixes for shutdown or resart, none of them have worked. The screen stays stuck on the Ubuntu with the 5 dots screen and I then push the button to complete the shut down. The last fix I tried was from this link So I've left issue for now and trying to get the wireless working, with no success on the contrary.

I've just installed the bcmwl-kernel-source package from these instructions.

The wireless connection still didn't work, so I shut down and rebooted.

Now after rebooting, there is still no wireless connectivity. The wireless switch on the computer is on. There is still no wireless choices in the menu bar. I decided to run the update manager and it doesn't work anymore.

Throws a Not all updates can be installed error with a list of reasons. When I press close, I get another error, this time Software index is broken, its impossible to install or remove any software - again with suggestions.

I then went and found on the forum how to uninstall what I had just installed through the terminal, hoping to get back to where I started from, since both the update manager and the terminal were working before the install.

The terminal gives me the following result:

sudo apt-get remove bcmwl-kernel-source.  
Message reads on the Terminal:  
E:  Could not get lock /var/lib/dpkg/lock - open - (11:  resources temporarily unavailable)
E:  Unable to lock the administration directory (var/lib/dpkg ), is another process using it?

Nothing is running in the background.

I'm rather exasperated since every move I make is bran new, and after spending days reading in the forum and trying what seems to work for others nothing does.

Before starting to try to fix the wireless today, everything in Ubuntu works beautifully, now if I can't do updates or use the Terminal, that's not so good.

share|improve this question
    
Do ps ax | grep -P 'apt|dpkg' edit your question and add the result. –  Braiam Feb 13 at 22:30
    
@Luis Alvarado I believe that is the incorrect duplicate. I'd like to answer it. –  chili555 Feb 13 at 23:01
    
@chili555 - Q has been re-opened and tags corrected to clarify this is an update-manager/packaging issue. –  fossfreedom Feb 13 at 23:13
    
Thanks for answering, I hope I'm writing this in the right place. I've typed in the command Braiam and this is the result I got: 1632 ? SNl 0:00 /usr/bin/python /usr/sbin/aptd 1673 pts/0 SNs+ 0:00 /usr/bin/dpkg --status-fd 14 --configure -a --force-confdef --force-confold 1677 pts/0 SN+ 0:00 /bin/sh /var/lib/dpkg/info/bcmwl-kernel-source.postinst configure 6.20.155.1+bdcom-0ubuntu0.0.2 2718 pts/1 S+ 0:00 grep --color=auto -P apt|dpkg ross@Workshop:~$ –  user247958 Feb 13 at 23:51
    
Please edit your question and add that information. BTW, something is definitively getting installed somewhere, check the Ubuntu Software Center for any open window, etc. Even if it's closed it could be waiting for your input. –  Braiam Feb 14 at 1:49
add comment

1 Answer 1

up vote 1 down vote accepted

The message "Could not get lock /var/lib/dpkg/lock - open" generally means the some other program to install or remove software is open; it may be Software Updater, Ubuntu Software Center, Synaptic or similar. Please find and close it. It may take a reboot.

bcmwl-kernel-source is incorrect for your 14e4:4312 device; you need to purge it. Please open a terminal and do:

sudo apt-get remove --purge bcmwl-kernel-source

And then get a temporary wired ethernet connection and install the needed firmware for your device:

sudo apt-get install firmware-b43-installer

After it completes, detach the ethernet and reboot. Your wireless should then be working.

share|improve this answer
    
I've reboot twice since I asked my original question and there is nothing open that I can see. I've done what you said Chili555 but no go. This what I got again sudo apt-get remove --purge bcmwl-kernel-source [sudo] password for ross: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? –  user247958 Feb 14 at 0:04
    
Please see here and read carefully before you proceed: askubuntu.com/questions/15433/… –  chili555 Feb 14 at 0:19
    
Thank you chili555, I've read most of the link and it feels rather scary to do. Since I am such a beginner at this, would doing a fresh install of Ubuntu be an option, that would clear up this problem? then I could follow you suggestion for installing the right firmware for my device? –  user247958 Feb 14 at 0:37
    
If you are willing to do a fresh install, I would first try the technique sudo rm /var/lib/apt/lists/lock and if that doesn't fix it sudo rm /var/cache/apt/archives/lock. I am fairly confident that one or both will fix it. If not, then reinstall. . –  chili555 Feb 14 at 0:53
    
I'll give that a try when I'm more rested and post my results. Thank you so much for being there chili555, I really like all the energy around this community! –  user247958 Feb 14 at 0:58
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.