Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently changed my Conky config so that when I 'Show Desktop' Super+D, Conky doesn't also minimize.

So I changed own_window_type normal to own_window_type override

This worked fine except when I boot Ubuntu it starts up with Conky on top of all windows. I have to kill and restart Conky for it to display properly.

share|improve this question
1  
Just a suggestion: a better way to prevent Conky from minimizing on Super+D is to keep the own_window_type normal line but also, under Compiz, General Options, unselecting "Hide Skip Taskbar Windows". –  Mandy May 11 '11 at 23:29

4 Answers 4

up vote 5 down vote accepted

After some searching around I found that an issue between Compiz and Gnome-WM meant that Conky was starting before Compiz was loaded.

The workaround is to delay starting Conky with examples suggesting about 20 secs.

  1. Create a new file with Text Editor named

    ~/.conkystart
    
  2. Paste the following code into the file and save it

    #! /bin/bash
    sleep 20 && conky
    
  3. Open Startup Applications and modify the Conky command to point to the file

There is also an alternative script which is more intelligent by using DBus to see if Compiz has loaded but this will not work on Natty due to an outstanding DBus Bug

Source: 1, 2

share|improve this answer
    
ah, you beat me to it. –  wojox May 11 '11 at 17:59
    
20 might be a little too much by the way - if your computer is not too old you can try lower values - mine works (worked, to more precise, i no longer use conky) just fine with "sleep 5 && conky" –  Chriskin May 12 '11 at 0:24

I added the command bash -c "sleep 15 && conky" to Startup Applications. That worked good for me.

share|improve this answer

Make it sleep while everything else loads:

#!/bin/bash

sleep 20 && conky;

Put that in a file name it .start_conky and right click to set it to executable. Then add it to your start up applications.

share|improve this answer
    
Using "sleep" solves the problem when you assume gnome (or unity) finished loading all needed data in less than 20 seconds. If your PC takes more than 20 seconds, then conky won't show properly. Sometimes it won't show at all. Is there another solid solution for this problem, besides increasing this time to 40 seconds or more? –  Leonardo Montenegro Mar 17 '13 at 1:59

A better solution than to use own_window_type override would be own_window_type desktop. On some machines the override option will put conky always on top of all windows, even if it is started later, on other machines override will produce no output at all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.