Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For a brief period of time i have had Ubuntu reinstalled, the 12.10 LTS version due to want to have encrypted harddrives (and that was the installaiton i could make the drives perform what i wanted)

Then i Upgraded from there, and want to use my Nvidia card, I run Ubuntu 13.10(for now) on an Acer Aspire Timeline X 4830TG With an Nvidia Geforce 540M graphics card.

My lspci -v gets me:

  VGA compatible controller: Intel Corporation 2nd Generation Core
 Processor Family    Integrated Graphics Controller (rev 09) (prog-if
 00 [VGA controller])   Subsystem: Acer Incorporated [ALI] Device 054f
    Flags: bus master, fast devsel, latency 0, IRQ 48   Memory at d1400000
 (64-bit, non-prefetchable) [size=4M]   Memory at c0000000 (64-bit,
 prefetchable) [size=256M]  I/O ports at 4000 [size=64]     Expansion ROM
 at <unassigned> [disabled]     Capabilities: <access denied>   Kernel
 driver in use: i915 


VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1) (prog-if 00 [VGA controller])   Subsystem: Acer
 Incorporated [ALI] Device 0550     Flags: bus master, fast devsel,
 latency 0, IRQ 16  Memory at d0000000 (32-bit, non-prefetchable)
 [size=16M]     Memory at a0000000 (64-bit, prefetchable) [size=256M]
    Memory at b0000000 (64-bit, prefetchable) [size=32M]    I/O ports at
 3000 [size=128]    Expansion ROM at d1000000 [disabled] [size=512K]
    Capabilities: <access denied>   Kernel driver in use: nouveau

I believe im running out of tricks, ive found several pages (about 20) and tried the most of them. Im back att running the default screen resolution in lightgdm, as i were before lowres and logging in to blank screeen.

The settings manager says to me that im running Intel-Sandybridge mobile.

I seem to have nouveau driver installed, and nvidia, But

cat /var/log/Xorg.0.log |less

>         [    30.605] (==) Matched intel as autoconfigured driver 0
>     [    30.605] (==) Matched nvidia as autoconfigured driver 1
>     [    30.605] (==) Matched nouveau as autoconfigured driver 2
>     [    30.605] (==) Matched intel as autoconfigured driver 3
>     [    30.605] (==) Matched vesa as autoconfigured driver 4
>     [    30.605] (==) Matched modesetting as autoconfigured driver 5
>     [    30.605] (==) Matched fbdev as autoconfigured driver 6
>     [    30.605] (==) Assigned the driver to the xf86ConfigLayout
>     [    30.605] (II) LoadModule: "intel"
>     [    30.605] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
>     [    30.613] (II) Module intel: vendor="X.Org Foundation"
>     [    30.613]    compiled for 1.14.5, module version = 2.99.910
>     [    30.613]    Module class: X.Org Video Driver
>     [    30.613]    ABI class: X.Org Video Driver, version 14.1
>     [    30.613] (II) LoadModule: "nvidia"
>     [    30.613] (WW) Warning, couldn't open module nvidia
>     [    30.613] (II) UnloadModule: "nvidia"
>     [    30.613] (II) Unloading nvidia
>     [    30.613] (EE) Failed to load module "nvidia" (module does not exist, 0)
>     [    30.613] (II) LoadModule: "nouveau"
>     [    30.613] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
>     [    30.615] (II) Module nouveau: vendor="X.Org Foundation"
>     [    30.615]    compiled for 1.14.2, module version = 1.0.9
>     [    30.615]    Module class: X.Org Video Driver
>     [    30.615]    ABI class: X.Org Video Driver, version 14.1

Seems i cannot load the module nvidia.

Believe me ive tried the most things i found, i messed about in grub, i installed purged reinstalled, nvidia, nouveau, bumblebee, blacklisted nouveau (unblacklisted it) all the tips you can find here about nvidia, several times, And i never did install the proprietary drivers,from Nvidias homepage. The software-proprieties-gtk command gave me no alternative drivers.

The reason i went from ubuntu or linux in the first place was because of nvidia drivers not working, (that was approx: 1 year ago) i dont want to mess about more and i am afraid that if i do i wont have patience to continue to get it to work. i already wasted to much time on this matter

share|improve this question
It looks like the nvidia driver is not installed, use CTRL + ALT + F2 to sign into a text session and post the output of dpkg -l | grep nvidia the output will show installed versions of nvidia, no output = not installed. –  mchid Jul 10 '14 at 13:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.