Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 12.04 LTS installed in as a VM in Oracle virtual box. I am able to browse from firefox but trying to connect from command prompt to update is failing. I also tried to change software sources but even then it is erroring out. The error is "Please check your Internet Connection".

PS : I am using NAT for networking.

What might be is issue and how to correct it?

share|improve this question
    
what kind of network connection setting has your virtual machine (NAT, Host-Only, ...)? –  Wolfgang Vogl Feb 13 at 11:01
    
Run software-center from a terminal and add the output to your question. –  minerz029 Feb 13 at 11:04
    
@WolfgangVogl I am using NAT. –  Shash Feb 13 at 11:10
    
Use Bridged and see if that solves your problem! –  SPRBRN Feb 13 at 11:25
    
hmmpf, while i used NAT i never had such an problem. My current configuration with a 12.04LTS as virtual machine (13.1 is my host) is to have adapter1 as NAT and adapter2 as host-only - for apt is use a proxy setting to use my host machine. On the host machine i'm running apt-cache-ng (my setup isn't this because it won't work, i just wanted to have my package in a comfortable cache...). But maybe THIS helps you: askubuntu.com/questions/143776/… - it tells you to set the hardware to AMD PCNet FAST III.. –  Wolfgang Vogl Feb 13 at 13:22
add comment

1 Answer 1

If you're using the default network type it's NAT. To keep NAT, you have to set up port forwarding like this. If you want to act more like a regular computer connected to your network, you want bridged like this.

The most common configuration for direct host to guest connectivity and internet connectivity is one host-only and one NAT interface.

My preferred configuration is bridged and host only, so I can access the machine directly and other machines on the network can access it if need be.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.